schiphol.nl - JavaScript access to Flash does not work

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Dutch
P3
normal
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Arjan van Vught, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030612

The following code starts a new window with unreadable characters.
 
javascript:LinkPopupWindow('http://www.schiphol.nl/media/flash/nl_plaza.swf','300','300','no')

Reproducible: Always

Steps to Reproduce:
1. GoTo http://www.schiphol.nl/, choose English
2. Click on: Parking & Train
3. Navigate to Maps and choose Map Arrivals
4. Click on "Click here for an interactive version of the map (Shockwave Flash)"
Actual Results:  
A new window pops-up with unreadable characters

Expected Results:  
It should start Shockwave Flash

Comment 1

15 years ago
--->INVALID

The web server is sending the wrong mime type for Flash:

[peterlub@localhost tmp]$ wget -S http://www.schiphol.nl/media/flash/nl_plaza.swf
--13:58:42--  http://www.schiphol.nl/media/flash/nl_plaza.swf
           => `nl_plaza.swf'
Resolving www.schiphol.nl... done.
Connecting to www.schiphol.nl[194.229.29.250]:80... connected.
HTTP request sent, awaiting response...
 1 HTTP/1.1 200 OK
 2 Server: Netscape-Enterprise/6.0
 3 Date: Thu, 19 Jun 2003 20:58:29 GMT
 4 Content-length: 73977
 5 Content-type: text/plain
 6 Last-modified: Wed, 12 Mar 2003 15:20:24 GMT
 7 Accept-ranges: bytes
 8 Connection: keep-alive

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
invalid is wrong
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
[pasting because of the mid-air with comment#1]

wget http://www.schiphol.nl/media/flash/nl_plaza.swf
--22:58:50--  http://www.schiphol.nl/media/flash/nl_plaza.swf
           => `nl_plaza.swf'
Resolving www.schiphol.nl... done.
Connecting to www.schiphol.nl[194.229.29.250]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 73,977 [text/plain]
----------------------------------------------------------------

The server sends the file as text/plain and Mozilla renders it as text/plain

->Tech Evang (broken Server)
The correct mime-type for this file would be "application/x-shockwave-flash"

Status: UNCONFIRMED → NEW
Ever confirmed: true
wtf ?
Assignee: peterlubczynski → dutch
Component: Plug-ins → Dutch
Product: Browser → Tech Evangelism
QA Contact: bmartin → dutch
Version: Trunk → unspecified

Updated

15 years ago
Summary: JavaScript access to Flash does not work → schiphol.nl - JavaScript access to Flash does not work

Comment 5

15 years ago
Gave feedback through their web form.
Priority: -- → P3
I couldn't find the flash map, the one I found was a dhtml map with proprietary
javascript :(
Whiteboard: [bug248549notfixed]

Comment 7

13 years ago
This specific problem seems to have disappeared, however please file a separate
bug for the DHTML map or notify promozilla.org. Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → FIXED

Comment 8

13 years ago
i looked at this the other day, but the main URL as listed in the URL box still
shows some problems. That's why i didn't mark it fixed.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.