POP3 get mail command produces a looped error window if a non-standard answer comes from the POP3 server

VERIFIED DUPLICATE of bug 178796

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 178796
15 years ago
14 years ago

People

(Reporter: Alan Franzoni, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

If the POP3 server answers with an error (a non standard error, I suppose) an
error window pops up telling the error. You click OK, and the same window comes
up again, and again, and again: the only solution is to keep ALT+F4 pressed to
close both windows (the popup window with the message, and the big MailNews
window) and then restart MailNews.

This happens to me on some POP3 accounts which, for instance, limit logins to
one every minute: if you click two times 'get messages' in a minute, a popup
window comes and says: 'The PASS command did not succeed. Mail server
etc.etc.com responded: [LOGIN-DELAY] Logins must be at least 1 minute apart'

You can try this on www.inbox.lv a free mail host.

Reproducible: Always

Steps to Reproduce:
1.Create an account on www.inbox.lv
2.Set up the corresponding MailNews POP3 account
3.Try getting mail twice in a minute.

Actual Results:  
A popup windows popped up telling me that logins should be 1 minute apart. I
clicked OK, and the window popped up another time, and more, and more and more,
until i kept ALT+F4 pressed to close the popup windows and the MailNews main window.

Expected Results:  
It should have told me the error just once, and then return to its normal
MailNews behaviour without retrieving mail from that account.

Comment 1

15 years ago
Sounds like bug 178796; Alan Franzoni, if you agree, please mark this bug as a 
duplicate of that.
(Reporter)

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 178796 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.