"Remove it immediately" does NOT delete from IMAP server

RESOLVED DUPLICATE of bug 83816

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 83816
15 years ago
10 years ago

People

(Reporter: Anthony Howe, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: 2003061008

I get copies of my email sent to my cell phone. And I occassionally delete
messages from the mail box to liberate space from my PC.  Today I actually
connected to the mail box via GPRS/WAP interface and found that all the messages
I  though had been deleted, had not been. 

Mozilla is set to access the account via IMAP and to "Remove it immediately"
when I delete messages. Mozilla happily deletes it from the message list but
fails to remove it from the IMAP server. I have to explicitly do a "Compact
folder" action, which I never had to do before with the old Netscape 4.79, when
using "Remove it immediately" option.


Reproducible: Always

Steps to Reproduce:
1. Create IMAP account, specify for "When I delete messages" option "Remove it
immediately".
2. Get email.
3. Delete email.
4. telnet imap.server.tld 143

1 login username password
2 select INBOX
3 logout

When you perform the IMAP SELECT command, it should report the number of
messages in the box.  Alternatively jump on the server and look at the mailbox
files.
Does it remove the messages if you close Mozilla ?
(The reason is AFAIk Undo )
You can find everything in bugzilla if you search...


*** This bug has been marked as a duplicate of 83816 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.