browser crashes while trying to load newtonproject's cul3970_w.xml

RESOLVED DUPLICATE of bug 209539

Status

()

Core
XSLT
--
critical
RESOLVED DUPLICATE of bug 209539
15 years ago
15 years ago

People

(Reporter: Samuli Kajantola, Assigned: peterv)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

Mozilla browser crashes every time while trying to load newtonproject's
cul3970_w.xml file on the specified URL.

Reproducible: Always

Steps to Reproduce:
1. Try to load the page on mozilla 1.4rc2 browser on any platform (confirmed on
Red Hat Linux 8.0 and Windows XP)
Actual Results:  
Mozilla browser crashes.

Expected Results:  
Mozilla should not crash but display errors on file if any.
Loading that page in a current debug build gives:

  Error loading stylesheet: An XSLT stylesheet does not have an XML
  mimetype:http://www.newtonproject.ic.ac.uk/web_keynes/ui/newton.xsl

and no crash.

Over to xslt, but I seem recall them fixing it on the trunk recently (too
recently for 1.4)
Assignee: heikki → peterv
Component: XML → XSLT
QA Contact: ashishbhatt → keith

Comment 2

15 years ago
I bet this is a dupe of bug 209539, which has a patch.
Reporter, did this happen on reload or so?
I can not reproduce this on my build with the patch, so I mark this as a dupe. 
Though it may as well be WORKSFORME, from what bz said.

*** This bug has been marked as a duplicate of 209539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Depends on: 209539
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
Axel: Not on reload, the browser crashes instantly at first load.
You need to log in before you can comment on or make changes to this bug.