Lists with Roman numerals don't fail gracefully for large numbers

RESOLVED FIXED

Status

()

Core
Internationalization
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: smontagu, Assigned: smontagu)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
The algorithm for numbered lists with Roman numerals in nsBulletFrame.cpp only
works up to 3999. Higher numbers display garbage.

(All other values for list-style-type either fall back to decimal above some
value or go on producing numerals in the same system up to MAXINT32. I can't
vouch that *every* system is working correctly, but there is no obvious garbage
except in the cases of upper-roman and lower-roman)
(Assignee)

Comment 1

15 years ago
Created attachment 126137 [details] [diff] [review]
Patch
(Assignee)

Comment 2

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 202604

Updated

9 years ago
Duplicate of this bug: 202604
You need to log in before you can comment on or make changes to this bug.