[PREFS] Theme provider's site link loads into prefs panel

VERIFIED FIXED in M14

Status

P2
minor
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: n.i.meara, Assigned: matt)

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description:

Clicking on the site link in the Themes preference panel loads the provider's
site into the panel replacing the UI.

Steps to Reproduce:

1) In the Prefs dialog select the Themes sub-item from the Appearance category.
2) In the Themes panel click on the link to the theme provider's site (in this
case mozilla.org).

Actual Results:

The mozilla.org homepage is loaded into the Themes panel completely replacing the
user interface elements.

Expected Results:

The mozilla.org homepage should be loaded into the frontmost browser window or a
new browser window. This may pose a problem, however, because the Prefs dialog is
modal.

Build Date and Platform:

1999120608 build on Mac OS 8.6

Additional Builds and Platforms:

1999120608 build on Windows NT 4

Updated

19 years ago
OS: Mac System 8.6 → All

Comment 1

19 years ago
[BugDay]This happens on Win NT build 1999120608 also.
It's really fun.
(Assignee)

Updated

19 years ago
Target Milestone: M13
(Assignee)

Comment 2

19 years ago
nice bug...easy fix

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M13 → M14

Comment 3

19 years ago
Ugh.  We should fix this one for beta 1.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
Fix checked in, patch provided by jst@citec.fr.
We now load into a new window.
Status: RESOLVED → VERIFIED
verified fixed on winNT and linux using 2000010308. however, setting theme on mac
caused a crash --opened new bug 22970 for that problem.

Comment 6

19 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.