If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[DOGFOOD]Overlong menu items appear blank, with no text

VERIFIED FIXED in M12

Status

()

Core
XUL
P2
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: fornixon, Assigned: David Hyatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
Overview Description:
menu item captions that are over a certain length cause the menu item to lack a
caption.

Steps to Reproduce:
1)start mozilla
2)open the Edit>Wallet, View, Debug, or QA menus, or right-click on a hyperlink.

Actual Results:
-the last item in the Edit>Wallet menu has no caption
-the menu item in View below Character Set Cryllic has no caption except for an
arrow. Moving the mouse over this item will cause the caption to appear as
Character Set Asian/Armenian/Semitic.
-under the Debug menu, the menu item under DOM viewer has no caption
-the last item in the QA menu
-the Open link in new window item on the hyperlink context menu lacks a caption

-Note that the menu items still work, there is just no prior clue as to what it
is going to do.

Expected Results:
-the menu elements should all be labelled. The menu should either get wired, or
the caption should be cropped in some way, but not entirely disappear.

Build Date & Platform Bug Found:
Build ID 1999120608, Win98

Additional Builds and Platforms Tested On:
none

Additional Information:
none
OS: other → All
Hardware: PC → All
Summary: Overlong menu item causes item caption to be invisible → [DOGFOOD]Overlong menu item causes item caption to be invisible
It seems to me like the disappearing items must be both longer than a certain
length and within a certain length of the longest thing on the menu.

I see this on Linux mozilla 1999-12-06-13-M12.  Marking All/All and marking
DOGFOOD.
*** Bug 21011 has been marked as a duplicate of this bug. ***
*** Bug 21014 has been marked as a duplicate of this bug. ***
The second of the bugs marked duplicate also notes that this occurs on
right-click context menus.
Another interesting thing (which I noticed as well) from the first bug is that
the longest item in the "View" menu appears once you hover over it (and then
continues to appear on subsequent use of the menu).
*** Bug 21014 has been marked as a duplicate of this bug. ***
Summary: [DOGFOOD]Overlong menu item causes item caption to be invisible → Overlong menu items make shortcuts invisible
yeah, i noticed it with today's build (1999-12-07-08m12) on linux as well.
updating summary to clarify that captions == keyboard shortcuts.
Summary: Overlong menu items make shortcuts invisible → [DOGFOOD]Overlong menu items make captions invisible
No.  The entire name of the menu item is invisible.  You can't tell what the
item is.

Remarking as [DOGFOOD].
Summary: [DOGFOOD]Overlong menu items make captions invisible → [DOGFOOD]Overlong menu items appear blank, with no text
Retitling again, to describe problem clearly.

Updated

18 years ago
Whiteboard: [PDT+]

Comment 10

18 years ago
Putting on PDT+ radar.
thanks for the clarification! also see this with today's linux build, eg,
trying to go to the page which is below Debug > DOM Viewer, the last items
under the Search, Bookmarks and Task menus, etc.

Updated

18 years ago
Assignee: saari → hyatt
Priority: P3 → P2
Target Milestone: M12

Comment 12

18 years ago
assigning to hyatt as p2 for m12
*** Bug 21062 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
*** Bug 21082 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
works well on NT, linux and mac --verified with 1999120808.

Comment 16

18 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.