Closed Bug 21019 Opened 21 years ago Closed 20 years ago

Menu layout/drawing problems (testing available screen space)

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: BenB, Assigned: mikepinkerton)

References

Details

Attachments

(1 file)

Large bookmark folders: while drawing, the upper half of the menu flashes for 2
min. or so. and blocks the complete UI (all of X11).
Mozilla seems to try to draw all of the menu on the screen, which of course
fails. We have to figure out, how many items will fit on the screen and draw
only them.
For test cases see bug #14540.
Summary: Test available screen space → Test available screen space: huge menus
clarified summary to fit with description. also added claudius, as he might see
this while working on bookmarks...
Summary: Test available screen space: huge menus → Test available screen space: huge menu redraw probs
more clarified. ;-)
Target Milestone: M13
This is a side effect of the implementation for bug #9454 .   Moving my bug
report from that bug to here:

With extremely large root menus (such as a bookmarks menu with 100 items), or
for any other root menu that has been moved up because it would run off the
screen, moving the mouse over a submenu causes the root menu to move up & down,
disappear and flash.
Status: NEW → ASSIGNED
Target Milestone: M13 → M15
Summary: Test available screen space: huge menu redraw probs → Menu layout/drawing problems (testing available screen space)
*** Bug 22155 has been marked as a duplicate of this bug. ***
Assignee: saari → pinkerton
Status: ASSIGNED → NEW
Taking menu/popup bugs.
giving to saari per our conversation.
Assignee: pinkerton → saari
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus
adding a couple mailnewsqa folks into cc: since we have an issue with cascading
large folder submenus in Move or Copy messages.  (ref: #15091 and #26151)
*** Bug 26151 has been marked as a duplicate of this bug. ***
Blocks: 26151
I am not seeing this anymore (2000020708 WinNT 4 SP6). Has this been fixed?
Pink, I think you fixed this, but I'll let you determine that
Assignee: saari → pinkerton
yes, i fixed this.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Problem still occurred on Mac9.0, for Mail folders..I cannot create new folder 
(1st level folder) from the server itself since it is out of the window....Cc: 
Seth.
eli or claudius: could you email me or attach a sample Huge Bookmark file so
that this can get verified soon? thanks!
Keywords: verifyme
i'm having problems verifying this one, on all 3 platforms --pls lemme know if i
should reopen this (or not), or open new bugs. this is what i've seen using
today's opt comm bits, 2000022808. what i did to test this is copy over
trudelle's big bookmarks file as bookmarks.html.

winNT & linux: because XPmenus aren't scrollable, the length (and therefore
content) of the bookmarks menu is limited by the monitor's screen size. i've
added a dependency on bug 11586 because of this --but lemme know if that's truly
relevant to this bug (i feel it is, imho).

mac: unlike winNT and linux, i can scroll further down the list...until i get to
the bookmark for "Map of Eric's Home Web" --after which subsequent bookmarks
just appear as "a" or "b". new bug?
Depends on: 11586
yeah, I'd say the mac issue was a new bug (i've seen it) but I wanted to verify it with some other large bookamrks file in case the 
one we've all been using is somehow corrupted. So if someone with a large enough bookmarks file wants to do that, that'd be 
cool. other than that new issue it sounds like this bug, as originally reported, is verified, no?
hokay, so verification of this is blocked by bug 11586.

as for the new mac issue --claudius, could you file that one once you get a
better large bookmark test (i only have what you and eli sent me, which is the
same thing :-)? thx!
Keywords: verifyme
sairuh, bug #11586 is related, I don't think there's a dependency.
claudius, there's a testcase attached to bug #14540.
this bug, as originally described, is fixed --ie, when trying to view a huge
bookmark list, i don't see menu flashing/etc. gonna verify this puppy --any
other problems w/large menus should be opened as separate bugs.
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.