mouse cursor does not change to indicators after opening an Event dialogue

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: anton.markov, Assigned: mostafah)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030616 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030621 Mozilla Firebird/0.6

When the mouse pointer is moved over a splitter/window separator, the pointer
does not change to indicate that it is moving over a splitter.  This does not
effect the splitter functionality; the splitter continues to work.  This occures
only if an event dialogue (new/edit) has been opened at least once in the
current session.

Reproducible: Always

Steps to Reproduce:
1. Open Calendar (close any previously opened Calendar windows)
2. Move the mouse over the splitter between the main calendar window and the
event list.
3. double click on any day to open the New Event dialogue (or open the Event
dialogue in any other way such as by editing a previous event)
4. close the dialogue
5. move the mouse pointer back over the splitter
6. restart Calendar
Actual Results:  
at step 2: the pointer changed to a double vertical arrow splitter indicator
at step 5: the pointer stays an arrow (does not change)
at step 6: the pointer changes as it should until you open an Event window

Expected Results:  
at step five the mouse pointer should have changed to indicate that it is
resting over a splitter like it does in step 2

calendar version: 	
Mozilla Calendar 2003061213-cal
(Reporter)

Comment 1

16 years ago
I just wanted to add that the mouse cursor is not changing at all after openning
an event dialogue.  Not only does it not change to indicate it is resting over a
splitter, but it doesn't change to a hand icon over the next/previous month
arrows, events, etc.

I have updated the Summary accordingly.
Summary: mouse pointer does not change to splitter indicator after opening an Event dialogue → mouse cursor does not change to indicators after opening an Event dialogue
(Reporter)

Comment 2

16 years ago
I have rebooted into Linux and found that this bug occures under Linux and under
Mozilla Seamonkey, not just Firebird.  Therefore, I believe this is a
cross-platform bug and am setting OS:All.

Here is my linux User-Agent:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617

My origional WinXP User-Agent (for reference):
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030621 Mozilla
Firebird/0.6
OS: Windows XP → All

Comment 3

16 years ago
Same thing happens when I try the steps to reproduce - Win Xp Pro on 1.4rc3 and
latest calendar build. 

Comment 4

15 years ago
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
Opening 'Print active calendars...' does the same thing.
'Preferences...', 'Edit calendar' and 'About' dialogs do not.

Strange.

Comment 6

14 years ago
*** Bug 259239 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 266601 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
Created attachment 163928 [details] [diff] [review]
patch setCursor("default") --> setCursor("auto")

Changes all instances of setCursor("default") to setCursor("auto") in calendar
javascript.

After setting to another cursor, such as setCursor("wait"), the way to set it
back is to setCursor("auto").

http://www.xulplanet.com/references/elemref/ref_XULWindow.html#prop_setCursor

Updated

14 years ago
Attachment #163928 - Flags: first-review?(mostafah)
(Assignee)

Updated

14 years ago
Attachment #163928 - Flags: first-review?(mostafah) → first-review+
(Assignee)

Comment 9

14 years ago
Checked in. Thanks
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.