%21%21channelname%21%21 causes cz to return no such channel when added to autostartup but manually joining #!!channelname!! works fine cz does reports !! as %21%21 but fails to reckognize it unless attached to server

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: pojordan, Assigned: bugzilla-mozilla-20000923)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cz-patch)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030620
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030620

%21%21channelname%21%21 causes cz to return no such channel when added to
autostartup but  manually joining #!!channelname!! works fine cz does reports !!
as %21%21  but fails to reckognize it unless attached to server

Reproducible: Always

Steps to Reproduce:
1.manually join at !!channelname!! and add it to auto join at startup
2.when it is added CZ sees the !! as %21%21
3.when you start your session error message will return that as not a valid channel
but you can then /join #!!channelname!! and there is no problem.

Actual Results:  
when you start your session error message will return that as not a valid channel
but you can then /join #!!channelname!! and there is no problem.

Expected Results:  
/join #!!channelname!!

reported error on #Chatzilla
(Assignee)

Comment 1

15 years ago
The problem lies here:
http://lxr.mozilla.org/mozilla/source/extensions/irc/js/lib/irc.js#1967

The problem is ChatZilla was not realising ! was special, so just blindly
removed the # to get the shorter URL. However, since the character after the #
*is* special, it must have the # prefix (%23). Patch in a minute.
Assignee: rginda → silver
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

15 years ago
Created attachment 141189 [details] [diff] [review]
Makes getURL only drop the # when the following character is safe
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Whiteboard: cz-patch
(Assignee)

Updated

15 years ago
Attachment #141189 - Flags: review?(rginda)

Comment 3

15 years ago
Comment on attachment 141189 [details] [diff] [review]
Makes getURL only drop the # when the following character is safe

Shouldn't we be using the prefixes from RPL_ISUPPORT?

Your call, r=rginda either way
Attachment #141189 - Flags: review?(rginda) → review+
(Assignee)

Comment 4

15 years ago
Comment on attachment 141189 [details] [diff] [review]
Makes getURL only drop the # when the following character is safe

Checked in.
(Assignee)

Comment 5

15 years ago
Checked in --> FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.