Unable to type in a URL when running Mozilla 1.4rc2 under X11 without a window manager

RESOLVED DUPLICATE of bug 78928

Status

()

RESOLVED DUPLICATE of bug 78928
15 years ago
15 years ago

People

(Reporter: anand, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617

System information:

Hardware: AMD MP 2000, nVidia GeForce 4 Ti 4200 card
Software: OS - Redhat linux 9.0, 2.4.20-18.9 kernel
               nVidia driver 1.0-4363
               X11 - XFree86-4.3.0-2

Description of problem:  When I run X11 without a window manager, i.e. I start
X11 using xinit and there is no WM running, I get a window with no window
manager controls (minimize, delete). This is as expected. At the shell prompt,
when I execute /usr/local/libexec/mozilla_1.4rc2/mozilla (which is where the RC2
binary of mozilla resides), I get a mozilla browser window with no window
manager controls, again as expected.

I cannot enter any URL into either the URL field on the Navigation toolbar or in
the URL field after opening a URL dialog with  "Open Web location"  because
there is no cursor and no apparent way of entering a URL. 
                      

Reproducible: Always

Steps to Reproduce:
1. Run xinit at shell prompt (without X11 already running.)
2. Execute the mozilla binary
3. Try to open a URL in either the URL field on the Navigation toolbar or via
"Open web location."

Actual Results:  
I cannot open any URL.

Expected Results:  
I should see a cursor in the Navigation toolbar URL field. I should be allowed
to type in a URL.

I'm using the Modern theme. I have not checked if the bug is reproducible with
the Classic theme.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 78928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.