Networking hang after loading page

RESOLVED DUPLICATE of bug 210119

Status

()

Core
Networking: HTTP
--
major
RESOLVED DUPLICATE of bug 210119
15 years ago
15 years ago

People

(Reporter: Olivier Cahagne, Assigned: Darin Fisher)

Tracking

({hang, regression})

Trunk
x86
Windows XP
hang, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
build ID: 20030622 on WinXP. Have to check with Mozilla in a few hours.

Recent regression (I believe in the last 7 days, it could also be the page
changed and this is related to a DNS issue).

Steps to reproduce:
1. Load URL http://blog.netpartoo.com/
2. somehow some inner resource doesn't load properly from http://www.rhone.fr/ ,
3. Firebird cannot browser any other site, CPU peaks at 98% and needs to be
killed manually.

Perhaps related: bug 210229, bug 210211.
Will try with Mozilla and get some networking log.
(Reporter)

Comment 1

15 years ago
also happen with Mozilla 2003061904 on Win2k.
Assignee: blaker → darin
Component: General → Networking: HTTP
Product: Phoenix → Browser
QA Contact: asa → httpqa
Version: unspecified → Trunk
(Reporter)

Comment 2

15 years ago
sniffer shows the following (using Mozilla 2003062004 on Win2k, will try again
with 20030623 as soon as it's uploaded on ftp.mozilla.org, could be fixed like
bug 210334 after june 22 builds)

GET /noheto/image/iillustrations/wifi.jpg HTTP/1.1
Host: www.rhone.fr:8080
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030620
Accept: image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Language: fr,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://blog.netpartoo.com/

HTTP/1.1 200 OK
Content-Type: image/jpeg
Content-Length: 22374
Content-Length: 22374
ETag: 
Content-disposition: inline; filename=wifi.jpg
Date: Mon, 23 Jun 2003 17:33:53 GMT
Server: Apache Tomcat/4.0.3 (HTTP/1.1 Connector)
Last-Modified: Mon, 02 Jun 2003 13:09:12 GMT
[...]

-> as it seems to be a regression from bug 209200.
What does bug bug 209200 have to do with this?  Is this fixed by the patch darin
checked in last night for bug 210119?
(Reporter)

Comment 4

15 years ago
sorry about bug 209200, it's obviously a typo, I cannot reckon what I initially
meant (too many beers...).
(Reporter)

Comment 5

15 years ago
works fine with a 20030624 build.

*** This bug has been marked as a duplicate of 210119 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.