Incomplete Help Index

VERIFIED FIXED in mozilla1.5beta

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: david, Assigned: rjkeller)

Tracking

Trunk
mozilla1.5beta
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030612

The Help index has sparse entries through the letter K and no entries beyond
that point.  

Reproducible: Always

Steps to Reproduce:
1.  On the menu bar, select Help > Help Contents.
2.  On the resulting Mozilla Help window, select the Index tab.  
3.  Scroll the index pane down.  

Actual Results:  
The number of entries becomes fewer and fewer.  From the letter L, there are no
entries.  

Expected Results:  
Since Help has information on Status Bar, I expected to see an Index entry for
that.  Nope!

Comment 1

16 years ago
Confirmed: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030620

This is related to bug 186235

Main tracking bug for help index related problems is bug 187558
Blocks: 187558
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

15 years ago
Created attachment 129406 [details] [diff] [review]
Adds help_index.html to the main index

The attachment takes all of the things that are in help_index.html file (which
is the old index) and puts them in the new index file. This seems to beef up
the index quite a bit :).

Comments?
(Assignee)

Comment 3

15 years ago
Created attachment 129436 [details] [diff] [review]
Patch 1.01

Same patch as above except that this is with the latest revision of the index.
(Assignee)

Updated

15 years ago
Attachment #129406 - Attachment is obsolete: true
(Assignee)

Comment 4

15 years ago
Comment on attachment 129436 [details] [diff] [review]
Patch 1.01

oeschger - could you please review? thank you!
Attachment #129436 - Flags: review?(oeschger)

Comment 5

15 years ago
Comment on attachment 129436 [details] [diff] [review]
Patch 1.01

r=oeschger
Attachment #129436 - Flags: review?(oeschger) → review+
(Assignee)

Comment 6

15 years ago
Created attachment 129477 [details] [diff] [review]
Patch 2.0

OK, this new patch has LOTS of stuff added to the index. I haven't done much
debugging with this so let's wait on reviews.

Sorry oeschger about having to do that review! I didn't notice how many more
items NS 7 had than Mozilla. These items were added to this patch so I might
require another review :), but not yet! this patch hasn't been properly
debugged yet.
Attachment #129436 - Attachment is obsolete: true
(Assignee)

Comment 7

15 years ago
Created attachment 129478 [details] [diff] [review]
Patch 2.01

OK! This is the final patch! This patch also fixes bug 215447, bug 197998, and
probably others. Lots of debugging went into this so it should be OK.
Attachment #129477 - Attachment is obsolete: true
(Assignee)

Comment 8

15 years ago
Comment on attachment 129478 [details] [diff] [review]
Patch 2.01

oeschger, would this require super reivew? I don't think so but not sure.
Attachment #129478 - Flags: review?(oeschger)
(Assignee)

Comment 9

15 years ago
Created attachment 129480 [details]
help-index1.rdf with patch 2.01 applied.

Comment 10

15 years ago
Comment on attachment 129478 [details] [diff] [review]
Patch 2.01

r=oeschger. hard to dig into this hard-to-read patch, but looks good. screw the
sr! let's check this in!
Attachment #129478 - Flags: review?(oeschger) → review+

Comment 11

15 years ago
adding to last comment: after appropriate approval has been asked for and given.
(Assignee)

Comment 12

15 years ago
should we try for 1.5b?

Comment 13

15 years ago
Comment on attachment 129480 [details]
help-index1.rdf with patch 2.01 applied.

asking for 1.5b approval for this content update to Help system
Attachment #129480 - Flags: approval1.5b?

Comment 14

15 years ago
Comment on attachment 129480 [details]
help-index1.rdf with patch 2.01 applied.

a=asa (on behalf of drivers) for checkin to 1.5beta
Attachment #129480 - Flags: approval1.5b? → approval1.5b+

Comment 15

15 years ago
FIXED. just checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

15 years ago
Reopening. Ian, this isn't in the latest build 2003081515. In fact, the index
got shorter!
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/extensions/help/resources/locale/en-US&command=DIFF_FRAMESET&root=/cvsroot&file=help-index1.rdf&rev1=1.8&rev2=1.9
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 17

15 years ago
--> me
Assignee: oeschger → webmaster
Status: REOPENED → NEW
(Assignee)

Updated

15 years ago
Target Milestone: --- → mozilla1.5beta
(Assignee)

Updated

15 years ago
Flags: blocking1.5b?
(Assignee)

Comment 19

15 years ago
timeless checked this in.

FIXED
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

15 years ago
*** Bug 217371 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking1.5b?

Comment 21

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.