Send or save draft hang on offline use; no timeout; compose window not responsive after cancel.

RESOLVED WORKSFORME

Status

MailNews Core
Composition
--
critical
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Matthew Elvey, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

Hitting send or save draft causes hang on offline use (specifically when the
composition is begun in online mode and sending is attempted in offline.)


Reproducible: Always

Steps to Reproduce:
0.Set up IMAP Draft/sent folders as destinations for draft/Sent email.
1.begin to compose while online
2.go offline
3.hit send/save draft


Actual Results:  
It never times out, and if cancel is hit, the compose window is not responsive
after cancel.  (Buttons, menus nonresponsive; closing the window prompts to
save, but sometimes it fails.

Expected Results:  
Send should have become "Send Later".  
Send attempt should have failed gracefully. 

Sorry if this is a dupe; I figure it must be, but I can't find one.
(Reporter)

Comment 1

14 years ago
Appears fixed (probably in a dupe bug) in Tbird 0.5, and probably recent Mozilla
Seamonkey's too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 2

14 years ago
->WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

14 years ago
If WORKSFORME was the appropriate resolution,
http://bugzilla.mozilla.org/bug_status.html needs to be changed to make that
clear; it indicates that FIXED is most appropriate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.