[regression] can paste multiple lines of text into a single-line text control

RESOLVED INVALID

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED INVALID
18 years ago
16 years ago

People

(Reporter: buster, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

18 years ago
until recently, you could only paste a single line of text into an <input
type=text>.  sometime in the recent past, this broke, and you can paste multiple
lines of text.

Updated

18 years ago
Target Milestone: M13

Comment 1

18 years ago
verified this on the 19991207 build on win32
(Assignee)

Updated

18 years ago
Whiteboard: fix in hand
(Assignee)

Comment 2

18 years ago
the problem was that the InsertText code no longer uses InsertBreak to insert
<BR>s.  Instead, we just put the newlines into the content model directly.
That's fine, but we were relying on InsertBreak() to check against mFlags to see
if we were a single line text control or not, and if so it would skip the
insertion of the <BR>.  Now, InsertText() needs to remove newlines itself.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: fix in hand
(Assignee)

Comment 3

18 years ago
fixed by replacing CRLF with spaces

Comment 4

18 years ago
*** Bug 22388 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
I think this bug has regressed again and needs reopening...

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

18 years ago
i have memories of someone removing the crlf conversion.  It was either me or 
someone I reviewed.  1.5 weeks of Florida vacation have erased further details 
from my mind.  I'll look into it. reopening bug...

Comment 7

18 years ago
ok, I talked to akkana about this.  This effect is intentional.  See bugs 23485 
and 50935.  closing bug invalid.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID

Comment 8

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 9

16 years ago
*** Bug 22388 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.