files not always visible on disk while download is in progress

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Andy Goth, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617

I like being able to access my files even before they are finished downloading
so I can check stuff like whether I have the proper codec, what the bit rate is,
whether the header is corrupted, the image resolution is, the language, the
abstract, and so on.  Besides, I *hate* losing files to browser crashes.

But sometimes when I download a file using Mozilla, the file isn't available on
disk until the download is complete.  Right now, I'm downloading libtool 1.5
(ftp) to ~ but the file isn't there.  Furthermore, I just cancelled it, and the
file is *still* not there... (Are cancelled files supposed to be deleted?  That
should be made an option.)

And sometimes it works as I expect it to...

Reproducible: Sometimes

Steps to Reproduce:
1. Download a file.
Actual Results:  
Sometimes the file doesn't appear on disk until it's completely done downloading.

Expected Results:  
I think it should always be there, no matter how incomplete the download is,
possibly with a .part suffix.

I just tested with {http,ftp}://ftp.gnu.org/gnu/libtool/libtool-1.5.tar.gz and
it failed both times.

Comment 1

15 years ago
FWIW, I can see why this is useful behaviour for newbie users -- but as a power
user, the ability to check the file during download is very valuable.

It can be digged up in /tmp, with a random filename and no extension.   But this
isn't exactly friendly. ;)

I'd suggest making this an option, defaulting to on; then people like myself and
Andy can turn it off and check downloads in progress.

Comment 2

14 years ago
The behavior has changed since 1.7a. Mozilla will move the file once you choose
a target directory. There it is the file with an extension .part until
completion. See Bug 55690. 
Reporter: So your problem is now solved? If so, please resolve this bug as fixed.
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.