Composer generates web pages incompatible with Internet Explorer

RESOLVED DUPLICATE of bug 210052

Status

--
major
RESOLVED DUPLICATE of bug 210052
16 years ago
14 years ago

People

(Reporter: joe, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

Same as in 2.7rc1,  Composer can generate pages that look just fine in Mozilla,
 but where the text lines do not wrap when viewed with Internet Explorer 6.0. 
An example of such a page is:
http://www.gpsinformation.org/hotspot/wirelesslansetup06182003.html

Anybody know a good workaround for this?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Long webpage text lines fail to wrap when viewed with IE6.

Expected Results:  
Long webpage lines generated by composer should word wrap when viewed by IE6.

Comment 1

16 years ago
The entire page is contained in a <PRE> tag, which means preformatted text.  

See the definition of <PRE> at
http://www.w3.org/TR/REC-html40/struct/text.html#h-9.3.4 which says: 
...
The PRE element tells visual user agents that the enclosed text is
"preformatted". When handling preformatted text, visual user agents:

    * May leave white space intact.
    * May render text with a fixed-pitch font.
    * May disable automatic word wrap.
...

The <PRE> tag contains an invalid WRAP="" attribute

The page is not valid HTML.  Please check the code at http://validator.w3.org/

Marking invalid, though it is interesting that Mozilla browser DOES wrap the text
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
*** Bug 210052 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

16 years ago
You say the page shown "is not valid HTML"?

It was generated exclusively by Composer.  If it is not valid html, then
composer has a bug.  
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

16 years ago
Perhaps I was not clear before.
1) The sample page was generated EXCLUSIVELY by composer.
2) There was NO manual html editing on the page after it was generated.
3) I did not in any way (that I know of) ask for the page to have this "pre
wrap" feature.
4) Since the page does not display properly in IE6, my conclusion is that
Composer is adding this "illegal" code in error.

Comment 5

16 years ago
While this might or might not be a bug (seems like it is), this is the same as
bug 210052 (which Joe already reported some time before this one).

*** This bug has been marked as a duplicate of 210052 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.