Infinite loop hang loading ESPN.com [@nsWritingIterator<char>::write(char const*, unsigned)]

VERIFIED DUPLICATE of bug 210119

Status

()

Core
Networking: HTTP
P1
critical
VERIFIED DUPLICATE of bug 210119
15 years ago
15 years ago

People

(Reporter: Christopher Aillon (sabbatical, not receiving bugmail), Assigned: Darin Fisher)

Tracking

({hang, regression})

Trunk
mozilla1.5alpha
x86
Linux
hang, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

Current linux CVS trunk -

Steps to reproduce:
1. Load espn.com

Expected results:
- Finished loading the page, like a good browser.

Actual results:
- Hang.

This is a regression from bug 208845.  Backing that checkin out locally fixes
this for me.  I have a stack trace, and a copy of the web page complete which
causes this hang.  I will attach both of those in the bug.
Created attachment 126274 [details]
Stack trace
Created attachment 126275 [details]
Web page, complete
Also note that there is an infinite loop of assertions.  Here is a bit of them
from the console:

CSS Error (http://ads.msn.com/ads/ :1.224): Unknown property 'filter'. 
Declaration dropped.
CSS Error (http://ads.msn.com/ads/ :1.116): Unknown property 'filter'. 
Declaration dropped.
###!!! ASSERTION: caller passing bogus length: 'aLength != PRUint32(-1)', file
../../../dist/include/string/nsDependentString.h, line 173
Break: at file ../../../dist/include/string/nsDependentString.h, line 173
###!!! ASSERTION: nsMemoryImpl::Alloc of 0: 'size', file
/usr/local/src/mozilla/trunk/mozilla/xpcom/base/nsMemoryImpl.cpp, line 322
Break: at file /usr/local/src/mozilla/trunk/mozilla/xpcom/base/nsMemoryImpl.cpp,
line 322
###!!! ASSERTION: You can't |write| into an |nsWritingIterator| with no space!:
'size_forward() > 0', file ../../dist/include/string/nsStringIterator.h, line 364
Break: at file ../../dist/include/string/nsStringIterator.h, line 364
###!!! ASSERTION: |copy_string| will never terminate: 'count_copied > 0', file
../../dist/include/string/nsAlgorithm.h, line 91
Break: at file ../../dist/include/string/nsAlgorithm.h, line 91
###!!! ASSERTION: You can't |write| into an |nsWritingIterator| with no space!:
'size_forward() > 0', file ../../dist/include/string/nsStringIterator.h, line 364
Break: at file ../../dist/include/string/nsStringIterator.h, line 364
###!!! ASSERTION: |copy_string| will never terminate: 'count_copied > 0', file
../../dist/include/string/nsAlgorithm.h, line 91
Break: at file ../../dist/include/string/nsAlgorithm.h, line 91
Summary: Hangs loading ESPN.com [@nsWritingIterator<char>::write(char const*, unsigned)] → Infinite loop hang loading ESPN.com [@nsWritingIterator<char>::write(char const*, unsigned)]
(Assignee)

Comment 4

15 years ago
probably a duplicate of bug 210119.
Status: NEW → ASSIGNED
Depends on: 210119
Priority: -- → P1
Target Milestone: --- → mozilla1.5alpha
(Assignee)

Comment 5

15 years ago
my patch for bug 210119 fixes this.

*** This bug has been marked as a duplicate of 210119 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified.  The patch works.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.