if percentage values are given for the width-attribute in a table or td it will often be (under unknown conditions) ignored on SUN-Platforms

RESOLVED DUPLICATE of bug 185949

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 185949
15 years ago
15 years ago

People

(Reporter: M. Wollatz, Unassigned)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030319
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030319

You'll find it on lots of pages that uses a Percentage-based Layout, if you use
a SUN to browse.(The same Pages browsed with Mac,Linux,Win32 are perfect)
Effect: Same as if you hadn't used a width-attribute at all!

e.g <table width="100%"> or <td width="20%">

using Stylesheets doesn't help. Since all Mozillas share common code for the
Render Engine, it seems a call to an os-dependent funktion went wrong?

I'm a little surprised about this error since it seems to hang around for many
versions. It's not just a Problem of a single Machine, each of our University of
Hamburg-Sunstations behaves the same. But I must admit I haven't checked it in
other networks just with older Mozilla Versions

Reproducible: Always

Steps to Reproduce:
1.Load http://home.t-online.de/home/iso.wollatz/index.htm
2.maximise window of mozilla
3.content (which is in Tables) will not expand

Actual Results:  
Content (which is in Tables) will not expand

Expected Results:  
Tables with 100% width should consume the whole screen,
and normally and otherwise does

Comment 1

15 years ago
*** Bug 210357 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
This bug sounds suspiciously like it's a duplicate of Bug ID: 185949
I remember having that problem when i was compiling Mozilla using Forte 6 or 7 
with an optimization value of X05. When i changed the optimization to X02 and 
recompiled again that layout problem was fixed.
Can you say what build of Mozilla you are using and what optimization flags 
were used to compile it.
Summary: if percentage values are given for the width-attribute in a table or td it will often be (under unknown conditions) ignored on SUN-Platforms → if percentage values are given for the width-attribute in a table or td it will often be (under unknown conditions) ignored on SUN-Platforms

Updated

15 years ago
OS: SunOS → Solaris

Comment 3

15 years ago
I've compiled a few older versions of Mozilla 1.3.1 and earlier with an
optimization flag greater then X02 with Forte and the percentage problem you
describe does occur with those builds, this is exactly the problem that occured
with Bug ID: 185949.
If you download a current version of Mozilla for Solaris from the Mozilla
website and try it on your web page you'll see that the page renders properly.
If you're compiling it yourself use the optimization flag of X02 and your
rendering problem will disappear.
I remember changing all my Intranet pages to use fixed widths for tables instead
of percentages before i figured out what the problem was.
This bug is a duplicate of Bug ID: 185949 and should be closed as a duplicate.

*** This bug has been marked as a duplicate of 185949 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.