If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Too big image gets auto-scalled down when next tab gets closed

VERIFIED DUPLICATE of bug 189982

Status

()

Core
Layout: Images
VERIFIED DUPLICATE of bug 189982
15 years ago
14 years ago

People

(Reporter: Marcin Orlowski, Unassigned)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       telnet/80
Build Identifier: 1.4rc2

I use tabbed interface (with "Hide the tab bar when only one tab is open" option
active - this seems to be important). I open the 1st tab, and point to huge
image (i.e. http://ishamael.tunkeymicket.com/images/ishzilla.jpg ) which does
not fully fits in my windows. Mozilla scales it down. I click on it to get it
back to real size and open 2nd tab. And when I close the 2nd tab, image on 1st
is being redrawn but also gets scaled down to fit the window area even it should
(as I didn't clicked it). It looks it does not happen when tab bar is always
visible ("Hide the tab bar when only one tab is open" if off)

Reproducible: Sometimes

Steps to Reproduce:
Described above.


Expected Results:  
Not scale image back unless ordered to.

Comment 1

15 years ago
In preferences, Appearance, does "Resize large images..." is checked or not ?
It clearly is.

The problem is that we ignore the current state on resize events, apparently....
(Reporter)

Comment 3

15 years ago
Appearance /  "Resize large images..." is ON

Comment 4

14 years ago
If you uncheck it, is the bug gone or not ?
(Reporter)

Comment 5

14 years ago
AFAIK this bug is not related to this option, but to the code it activates. If
the option is OFF, the code is OFF hence the reduced opportunity to malfunction ;)

Comment 6

14 years ago
depend/dup of bug 189982
since toggling tab bar (or toolbars or status bars for that matter) resize the
display area, it's probably the same.

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 189982 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 8

14 years ago
V/dupe.
Status: RESOLVED → VERIFIED
Component: Browser-General → Layout: Images
QA Contact: general → benc
You need to log in before you can comment on or make changes to this bug.