bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Cannot move a message if it is over at least 213K



MailNews Core
Networking: IMAP
15 years ago
9 years ago


(Reporter: Taj Morton, Assigned: Bienvenu)


Windows 98

Firefox Tracking Flags

(Not tracked)



(6 attachments)



15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030612

I recieved a virus a while back through email. Since I'm using Mozilla MailNews,
I didn't get infected and just hit delete. When I was moving my trash from my
IMAP server to my hard drive, it kept stopping at that one email with a virus. I
would have to restart the whole Mozilla (MailNews and whatever else I had open,
eg the Browser).

Reproducible: Always

Steps to Reproduce:
1. Go to an IMAP folder (this _could_ affect other protocols, but I haven't
tested it).
2. Try to move a few messages with a large message selected as well (you can
also select a single message). I had 213K, but it might be able to be smaller.
Actual Results:  
Mozilla stopped moving messages at the large message.

Expected Results:  
Mozilla should have kept moving messages.

Comment 1

15 years ago
Most likely the virus message has an embedded null, and it has nothing to do
with the size of the message. What IMAP server are you using? IMAP servers are
not supposed to send embedded nulls according to the IMAP RFC but some versions
of some servers do.
Ever confirmed: true

Comment 2

15 years ago
I am using the Outblaze (www.outblaze.com) IMAP server through Linuxmail
(www.linuxmail.org). Here are the full headers (w/o message):

Return-Path: <jlvarga@cox.net>
Delivered-To: tmorton:linuxmail.org@linuxmail.org
Received: (qmail 14839 invoked by uid 0); 19 Jun 2003 18:00:42 -0000
Received: from unknown (HELO spf5-2.us4.outblaze.com) (
  by 205-158-62-130.outblaze.com with SMTP; 19 Jun 2003 18:00:42 -0000
Received: from fed1mtao02.cox.net (fed1mtao02.cox.net [])
	by spf5-2.us4.outblaze.com (Postfix) with ESMTP id AF58019A75A
	for <tmorton@linuxmail.org>; Thu, 19 Jun 2003 18:04:00 +0000 (GMT)
Received: from lukErcaB ([]) by fed1mtao02.cox.net
          (InterMail vM. 201-253-122-122-105-20011231) with SMTP
          id <20030619180350.DHOE20281.fed1mtao02.cox.net@lukErcaB>;
          Thu, 19 Jun 2003 14:03:50 -0400
From: "MS Network Security Division" <muxfjseuzjqltpycsw@updates.microsoft.net>
To: "MS User"@spf5-2.us4.outblaze.com
SUBJECT: Microsoft Security Pack.
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="OUxuVkvAjzTGrp"
Message-Id: <20030619180350.DHOE20281.fed1mtao02.cox.net@lukErcaB>
Date: Thu, 19 Jun 2003 14:03:58 -0400

Content-Type: multipart/alternative; boundary="CySZqoqfxEnlmTLrT"

Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

What should I look for to tell if it has an embedded null?

I can send the virus over if you want ;-). Don't worry, it doens't execute
unless you run MS Outlook (and I assume you don't).

Comment 3

15 years ago
Here's what you can do. Generate an imap protocol log by following these


You want to generate a log of selecting the virus message and trying to copy it
to a local folder and then attach the log to this bug or e-mail it to me. The
embedded null is most likely in the message body.

Sending me the message won't help because our IMAP server will not allow the
embedded null, since it's illegal. I'd like to make our code more tolerant of
embedded nulls, at least in the message body, but without a server that will
generate them, it's hard to test :-)


Comment 4

15 years ago
Aarg!! I deleted the message, sorry :-(. Is there any file that might still have
it. I haven't restarted Mozilla yet.

Comment 5

15 years ago
If you deleted it from your inbox, it might still be in your inbox, but just
with the deleted flag set. What you can do is start up Mozilla, and switch your
imap server settings to "when I delete messages, mark them as deleted", instead
of "move them to the trash". Then, click on your inbox, and see if the message
is still there. However, if you have "expunge inbox on exit", it might already
be gone. If it's still there but with a big red x, you can "undelete" it by just
pressing delete again.

Comment 6

15 years ago
Created attachment 126301 [details]
Log of trying to move message from local to IMAP

Thank you! I got the message. Here is a log of trying to move it from local to
the inbox on my IMAP server. It failed. It also failed trying to move from
Trash on IMAP to local, but suceeded on moving from IMAP Inbox to local trash.

Comment 7

15 years ago
I'll be gone for 3 days FYI. No email.

Comment 8

15 years ago
before you go, can you attach a log of just reading the message in your imap
inbox? thx!

Comment 9

15 years ago
Back. There is a log of reading it and moving it up (and there was one before,
too, though)

Comment 10

15 years ago
OK, the log that's attached doesn't show the reading of a message (this could be
because you have the INBOX configured for offline use, and we've already
downloaded the message body). But it's more likely that it's just a log of
moving a message from a local folder to an imap folder. What I was hoping to see
was a log of that message getting selected in an imap folder, so I can see the
contents of the message.

Also, could you try a 1.5 trunk build from yesterday or today? I fixed our
handling of IMAP syntax errors (e.g., the server returns the message incorrectly
because of embedded nulls in the message).

Comment 11

15 years ago
Created attachment 126582 [details]
Log of selecting the message

Here is selecting the message on the IMAP server with 1.4 rc2. I'm on dialup
(38KBps), so I'll download todays build and send in a log.
Attachment #126301 - Attachment is obsolete: true


15 years ago
Attachment #126301 - Attachment is obsolete: false

Comment 12

15 years ago
Created attachment 126590 [details]
Log message of selecting message w/ 1.5 trunk

Here is the log generated by selecting the message with 1.5 trunk (build
2003062608). OK. So it also got my mail ;-). Ignore the first section...

Comment 13

15 years ago
OK, one more try (those logs look fine so I can't see the problem from them :-( )

Can you attach a log where you do the following:

1. Select the problem message.
2. Move it to a local folder.

I'm not sure it'll show anything different, but since that was the original
problem scenario, it's worth a try. Thx!

Comment 14

15 years ago
Created attachment 126592 [details]
Selecting and moving message

This is the log of selecting and moving the message. Once with it being the
only one being moved, the other time with another message selected. It didn't
hang this time. The reason I tried moving another message is because it caused
the move to fail. Using 2003062608. Maybe you fixed it?

Comment 15

15 years ago
The new log is zipped up so I can upload it. Sorry :-(. I wish I had some server
space with my ISP...

Comment 16

15 years ago
Created attachment 126597 [details]
Moving of two messages failing

OK. Here is a log using 2003062608. I selected and attempted to move (to a
local folder) two messages. It didn't work.

Comment 17

15 years ago
OK, thx, that last log is interesting. We're trying to read two messages and 
nothing's coming back from the server, because those two messages don't exist 
in the folder. In fact, the Trash is really empty - all the messages in it are 
deleted, according to the server. I'm not sure why we're letting you select 
them in the UI in the first place.

Comment 18

15 years ago
Weird. From the web interface of my mail system, they don't show up. Weird.

Comment 19

15 years ago
Created attachment 126624 [details]
Attachment not showing w/ virus

This is another log of trying to view a message with 2003062608. It shows up,
but not the attachment. I can see the message. Any ideas?

Comment 20

15 years ago
are you accessing your inbox with web mail at the same time as you access it
with Mozilla? That can cause problems, though it still wouldn't explain what I
see in the log.

Comment 21

15 years ago
No, I am not. I am not accessing the mail interface when I am connected to the
server via Mail. It was when I was booted into Linux that I checked the web mail

Comment 22

15 years ago
This looks like it might be a problem with the server - we ask for the body
structure of the message, and the server starts complaining and returning
untagged OK responses. Those should be ignored by the parser, I think, but it is

16 UID fetch 1056724485 (BODYSTRUCTURE)

-734181[23c3580]: ReadNextLine [stream=23c31d8 nb=0 needmore=1]
-734181[23c3580]: ReadNextLine [stream=23c31d8 nb=79 needmore=0]
23c2650:linuxmail.outblaze.com:S-INBOX:CreateNewLineFromSocket: * OK [PARSE]
Must use comma to separate addresses: mailerautomat recipient <>

-734181[23c3580]: ReadNextLine [stream=23c31d8 nb=32 needmore=0]
23c2650:linuxmail.outblaze.com:S-INBOX:CreateNewLineFromSocket: * OK [PARSE]
Missing parameter

-734181[23c3580]: ReadNextLine [stream=23c31d8 nb=265 needmore=0]
23c2650:linuxmail.outblaze.com:S-INBOX:CreateNewLineFromSocket: * 50 FETCH (UID
"<uvbmrsh>" NIL "BASE64" 212994 NIL NIL NIL) "ALTERNATIVE" ("BOUNDARY"
"UNfZZuUqxbjNwhY") NIL NIL))

-734181[23c3580]: ReadNextLine [stream=23c31d8 nb=27 needmore=0]
23c2650:linuxmail.outblaze.com:S-INBOX:CreateNewLineFromSocket: 16 OK UID FETCH
Product: MailNews → Core

Comment 23

10 years ago
David, I think reporter Taj is gone. Should the "null" issue be followed up on?
QA Contact: grylchan → networking.imap

Comment 24

10 years ago
No, I think that's handled in other bugs. It looks like this really was a server issue.
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.