Closed Bug 210401 Opened 18 years ago Closed 17 years ago

Immediately opening a new browser tab after visiting a page with an auto-placed cursor takes cursor focus from current page to original page

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: talibmorgan, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

I use www.hotmail.com as the URL because that's where I see the problem. 
However, the best way to actually experience the problem is to go to
www.msn.com.  Then, click on the "Hotmail" nav item at the top.  Right after
clicking the "Hotmail" item, but before the page loads, open a new tab window
(Ctrl+T) and try to type in a new URL in the address bar (e.g. www.mozilla.org).

When the Hotmail page loads, it automatically places the cursor in the "E-mail
address" field.  Unfortunately, doing so seems to steal cursor focus from
separate and distinct tabbed browser windows.  It does not seem to happen when
new non-tabbed (Ctrl+N) browser windows are created.

I find it mildly annoying and since I'm seeing more and more sites auto-placing
the cursor, I'm guessing that it will only get more annoying.

Reproducible: Always

Steps to Reproduce:
1.  See the Details section above.

Actual Results:  
My cursor moved from my current tabbed browser window to the one in which
Hotmail had loaded.

Expected Results:  
It should have kept my cursor's focus where I had it.  When I went back to the
Hotmail window, I would see the cursor in the "E-mail address" text box.  That's
the behavior that I see when I use Ctrl+N instead of Ctrl+T.  I'm guessing that
tabbed browser windows share a cursor object someplace, but new browser windows
have separate cursor objects.
This bug (report) looks like a duplicate of bug 210367...
All these bugs seem the same (focus changes to form element after new tab):
Bug 200942, bug 200231, bug 196646. Maybe bug 200664 too.
It seems to happen to me on RedHat9 since 1.5a and on to current 1.5.

I usually fix it by changing to the mail component, pressing the "Get Mail"
button and going back to the browser. It doesn't work always, though.

It's a very annoying bug.
Something similar happens to me when I have multiple tabs open. Seems like my
keyboard navigation is going to a tab in the background, so when I hit pgdn,
end, etc. the tab behind the one that's visible is getting those keystrokes
instead. I can switch to the other tab and find that the page has been advanced
as though I had been hitting those keys while viewing that tab (which wasn't the
case). I'm using (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b)
Gecko/20040102 Firebird/0.7+).

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.