Visiting apple.com causes CPU Usage ~100%. Closing the last open Window doesn't kill Firebird

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: jhatax, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Version: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4b) 
Gecko/20030622 Mozilla Firebird/0.6
OS: Windows Server 2003

Description:
--------------
- Firebird chokes (and must be force killed) when rendering www.apple.com. 
- CPU usage goes to nearly 100% (95-98%). 
- Closing the last open window doesn't kill Firebird (it's stuck trying to 
complete some request) and I need to go to Task Manager to force kill the 
process.

Steps to Reproduce:
--------------------
1. Start Firebird 
2. Type www.apple.com in the location bar
3. Bug reproes on Windows XP/Server 2003

On further investigation, I found the following animations on the page:

1. 
http://a1104.g.akamai.net/7/1104/51/481dca1bdfe4b3/www.apple.com/home/images/20
03/06/powermacG5title06232003.gif

2. 
http://a912.g.akamai.net/7/912/51/0ab2e2fa0fadd2/www.apple.com/home/images/2003
/06/spticker06232003.gif

Could this be a regression related to the handling of Animated GIFs in 
Firebird or related to the patch that Stops Animations by clicking the Stop 
button?

Comment 1

16 years ago
CONFIRMING, I think...

I can't reproduce this going to the Apple.com site, but I've seen this same
behavior over the last couple of days with various sites.  I don't believe it's
related to the site itself, but I haven't been able to figure out what causes it
yet.

I think it's network-related, because every time I've seen this happen, it's
been accompanied by:
1) Status bar says "Stopped" for the last site I visited.
2) Going to any new site results in throbber spinning, but no new message on
status bar (i.e. no connection, transferring or waiting messages).
3) Quitting Firebird causes the window to disappear, but the process remains in
memory using close to 100% CPU.

I would guess the summary should probably be changed to describe this more
accurately, but I'll leave it as is for now.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Looking for other networking bugs, I see that this may be dupe of bug 208503.

Comment 3

16 years ago
Seeing this at http://www.apple.com/g5/
Same behaviour as reported, and networking seems broken also.
Tested with Seamonkey build 2003062004.

Comment 4

16 years ago
WFM with build 2003062312, maybe a dup of bug 210119 ?
(Reporter)

Comment 5

16 years ago
This isn't a duplicate of 210119 - visiting that URL (realitytimes blah) 
causes Mozilla to crash, this bug makes Mozilla unusable and unresponsive - 
CPU usage shoots up to 98% on my 2.4 GHz Pentium 4 machine.

This doesn't only happen on apple.com but on random sites and more 
consistently when more than 1 tab is open.

Very irritating, I'm tempted to revert back to the nightly of 3 June 2003...

Comment 6

16 years ago
Reporter, do you get the "Stopped" in the status bar?  I'm trying to figure out
if what I'm seeing is really your bug or not.
(Reporter)

Comment 7

16 years ago
I get Done - but I've noticed this using Firebird not Mozilla - so maybe, they
Stopped and Done are equivalent
(Reporter)

Comment 8

16 years ago
Also, at this very instant, as I type this using Firebird 20030620, CPU usage is
~100% but I can still enter information on the page and submit my bug reports.
The build numbered 200300622 doesn't even finish rendering the page with the CPU
at ~100%. I can go back to an earlier build and determine when this started
occurring!

Comment 9

15 years ago
This WFM on 0.6.1rc1 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030725 Mozilla Firebird/0.6)

Can we get some more testcases or confirmation of this WFM please?

Comment 10

15 years ago
Also WFM with Gecko/20030723 Mozilla Firebird/0.6, Windows XP.
Reporter, is this still present on your platform?  If not I will be marking this
as WORKSFORME.  Thanks!
QA Contact: asa → mconnor
(Reporter)

Comment 12

15 years ago
This doesn't reproduce anymore - marking WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 13

15 years ago
Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614
Firefox/0.9
OS: Windows XP

I'm experiencing this problem on the Overture.com login page:
https://secure.overture.com/s/dtc/center/?mkt=us

The Status Bar displays "Transfering data from a248.e.akamai.net..."

Sometimes on the Overture main page (http://www.content.overture.com/d/) the
page completes loading (throbber stops spinning) but the Status Bar displays
"Transfering data from a840.g.akamai.net..."

The connection seems to be content akamai.net; content from this site was
mentioned in Comment #0.

Firefox is unresponsive and takes up about 99% of the CPU.  Must be killed with
Task Manager or "End Now" in End Program dialog box.
You need to log in before you can comment on or make changes to this bug.