Closed Bug 210431 Opened 19 years ago Closed 19 years ago

When simultaneously loading pages and currently inside a tabbed page containing a text input form, other tabs will "steal" focus

Categories

(SeaMonkey :: Tabbed Browser, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: n1357911, Assigned: jag+mozilla)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

When a tab finishes loading, it appears to "focus" itself; when there are
multiple tabs loading the bug can be revealed.  If a person in tab A is typing
text in an "input text form"* and then tab B completes, tab B can "steal" the
focus of tab A thus the typing text from tab A will be "dumped" into tab B's
"input text form".


*"input text form" - the input text cell where
<form><input type="text" name="blah"></form>
is the html

Reproducible: Always

Steps to Reproduce:
This is hard to reproduce if the "trial" pages are cached and/or if the client
has a fast internet connection.  (I am at school right now and I can't reproduce
it because of a T1 connection.)  It is very easy to reproduce on a 56k connection.

Below are instuctions recollecting from memory.  I have reproduced this on my
home machines: "mozilla firebird/redhat linux8", "phoenix0.5/win2000".  (It has
also been replicated on netscape7.02/mac9.2 so I believe the "bug" to be on all
platforms)

1.  Load "New -> Navigator Window"
2.  Use the appropriate tab shortcut key
("Alt-t"=linux,"Ctrl-t"=windows,"apple-t"=mac) and load a page that contains a
form with a "input text" (such as "mail.yahoo.com") and then open other tab
(such as www.linuxmail.org)

-let the first tab be called "tab A"
-let the second tab be called "tab B"
-note: tab A and tab B pages should include pages with "input text form"s

3. Quickly, while tab B is still loading, in tab A type into the input text form
until tab B completes.  You will find that tab B has "stolen" tab A's focus and
the typing text "ends up" in tab B's input text form.


Actual Results:  
You will find that tab B has "stolen" tab A's focus and the typing text "ends
up" in tab B's input text form.


Expected Results:  
Retain the focus in tab A.  Before a tab completes and assumes it should be
focused, it should check if another tab is already focused.

If the instructions are found inaccurate, let me know; I can reproduce it on my
56k connection home machine.  The connection I am using right now is too fast
for reproducing the bug.

I have experienced this bug on:
phoenix0.5/win95
phoenix0.5/win2000
phoenix0.5/linux RH8
mozilla firebird/linux RH8
netscape7.02/mac9.2  <- verifies that is across the main OS platforms

Bug does not affect functioning, but it is an annoyance.
Do you see this with Netscape7.02 or a recent Mozilla build like Mozilla1.4RC2 ?
I see this behavior on Netscape7.02 on Mac 9.2 at school; I have not yet the
chance to test this on Mozilla1.4RC3 that was released yesterday, but this
behavior is seen in Mozilla Firbird on Linux also.
confirming for Firebird 20030626 on W2K SP3
This is a dupe of bug #124750

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.