upg. 1.3->1.4rc2 caused duplication of personal toolbar bookmarks

RESOLVED INVALID

Status

SeaMonkey
Bookmarks & History
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Brett Russ, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

I just upgraded from 1.3 -> 1.4RC2 and I am pretty sure this caused *most* of my
personal toolbar folder links *within folders* to be duplicated.  Problem did
not affect "standard" bookmarks or direct bookmarks in the PTF.

I have 14 folders and 3 direct links in the PTF.  Out of those, 11 folders had
all of their actual bookmark contents duplicated.  None of the subfolders were
duplicated, but their contents were.

I'll clean up this mess and try to repro...

Reproducible: Didn't try

Steps to Reproduce:
1. Start with 1.3 (I believe it was 20030302 or something in early March)
2. Use the windows installer and choose custom install and deselect everything
possible.  Installed in default dir but start menu location modified.  Use quick
launch.
3. When Mozilla launches, check PTF in toolbar of window.

Actual Results:  
See details.

Expected Results:  
Left PTF BM's alone.
(Reporter)

Comment 1

15 years ago
Just successfully reproduced.  If you need more details let me know.  Thanks.  I
will continue with 1.4RC2.

Comment 2

15 years ago
Have you installed 1.4rc2 over 1.3 or did you uninstall 1.3 first (or did you
choose another dirrectory)?
(Reporter)

Comment 3

15 years ago
Installed over the existing 1.3 into the same directory.  For both installs (1.3
and 1.4rc2) I chose the default directory, a modified start menu location
(nested it one level deeper), chose only the browser, mail/news, and qual.
feedbk. components, and used the quick launch feature.

Comment 4

15 years ago
You're not supposed to install on top of another installation. In the release
notes it is stated that this may lead to problems.

INVALID. Please reopen (or comment if you can't) if this also happens after
installing into a clean directory.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

15 years ago
Performed a fresh install of 1.4rc2 on a different box and it worked fine.

Some things to note:

-I've installed over the previous installation every time since pre-1.0 I
believe.  This is the first time I've had problems.

-If fresh installs are the only thing that are supported, should the install
procedure offer to uninstall a previous version if someone tries to install over
it (which I'm sure many do)?  I think it should, but that's another bug report...

Thanks for all the great work on this browser and MUA.  Just last night I
migrated all of my home email and contacts from Outlook to Mozilla Mail and am
discontinuing Outlook use.  Thank you for "freeing my mind".
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.