Empty header redirect ("Location: ") hangs browser

VERIFIED DUPLICATE of bug 210119

Status

()

--
critical
VERIFIED DUPLICATE of bug 210119
16 years ago
15 years ago

People

(Reporter: yem, Assigned: bugzilla)

Tracking

({hang, regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030620 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030620 Mozilla Firebird/0.6

*WARNING* The URL attached to this bug will (probably) CRASH Firebird.

The example URL returns:

HTTP/1.1 302 Found
Date: Tue, 24 Jun 2003 04:31:37 GMT
Server: Apache/1.3.26 (Unix) PHP/4.2.2 mod_ssl/2.8.10 OpenSSL/0.9.6e
X-Powered-By: PHP/4.2.2
Status: 302
Location:
Connection: close
Content-Type: text/html

This hangs MozillaFirebird (CVS build as of Fri 20 June 2003).

Reproducible: Always

Steps to Reproduce:
Go to http://www.dotster.com/favicon.ico in MozillaFirebird.
Actual Results:  
MozillaFirebird hangs with 100% CPU usage.
I can enter new URLs but they don't load.

Expected Results:  
Unknown. Treat as 404?

Using gentoo, with package net-www/mozilla-firebird-cvs.
(Reporter)

Comment 1

16 years ago
This trivial PHP script produces the same behavior:

<?php
        header("HTTP/1.1 302 Found");
        header("Test: abc");
        header("Location: ");
?>
 
Hello, world.

Comment 2

16 years ago
Zach, this works for me using latest Mozilla/5.0 (Windows; U; WinNT4.0; en-US;
rv:1.5a) Gecko/20030623 Mozilla Firebird/0.6 => please re-test with latest
nightly, since I was able to see your problem using yesterdays nightly.

Additionally this sounds like a dupe of bug #210047 since I can see the exact
same regression time frame for your problem: the first build which shows both
your problem and bug #210047 was the 2003-06-19 build.

=> adding whiteboard & keywords, changing OS to "All"
Keywords: hang, regression
OS: Linux → All
Whiteboard: WFM? possible dupe of #210047

Comment 3

16 years ago
WFM with 20030622 build
(Reporter)

Comment 4

16 years ago
Rebuilt from CVS as at 2003-06-27. Bug is fixed.
It seems to simply ignore the invalid 'Location' header, which sounds reasonable.
Erik, tracing through the bugs, the real bug I would dupe this under is bug
210119, since that's the one that the fix is under.  210119 IDs this as a 
regression caused by the fix for bug 208845.

I should really bug Gerv about getting editbugs at some point, instead of all
these "Erik can you do this, can you do that?" comments!

Comment 6

16 years ago
Yeap, I'll dupe this because of bug #210119 - that's also the one to dupe bug
#210047 like already mentioned there... 

=> removing status and dependency

*** This bug has been marked as a duplicate of 210119 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 210047
Resolution: --- → DUPLICATE
Whiteboard: WFM? possible dupe of #210047

Comment 7

15 years ago
verified DUPLICATE 2003-ß9-03
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.