text/html clipboard import breaks for > ca. 4300 bytes

RESOLVED DUPLICATE of bug 56219

Status

defect
RESOLVED DUPLICATE of bug 56219
16 years ago
15 years ago

People

(Reporter: hellan, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

There seems to be an upper size limit on text/html clipboard import to the
composer. But there may be more to it than that.

From Gnumeric HEAD, I was able to paste a selection of length 3951 but failed
for length 4290.
From OpenOffice 1.1Beta2 Calc, I was able to paste a selection of length 1011
but failed for length 1121.

Length is measured by (length (x-get-selection 'CLIPBOARD 'text/html)) in Emacs
21.2.1. I assume that it returns bytes.

Both selections contain a table in an html body, UTF-8 encoded. OpenOffice is 
HTML 3.2, Gnumeric is XHTML 1.0 Transitional.

I don't hit this size limit when pasting between Gnumeric and OpenOffice.

Reproducible: Always

Steps to Reproduce:
1.Mark a small range in spreadsheet and copy to clipboard
2.Paste into composer
3.Mark a bigger range and try again 
  Repeat 3 until pasting fails.

(length (x-get-selection 'CLIPBOARD 'text/html)) in the Emacs scratch buffer
tells you how large the clipboard selection is.
(x-get-selection 'CLIPBOARD 'text/html) tells you what it contains.
Actual Results:  
For a big enough spreadsheet range, nothing shows up in composer 

Expected Results:  
a table should turn up in composer.

*** This bug has been marked as a duplicate of 56219 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.