Closed Bug 210513 Opened 17 years ago Closed 16 years ago

browser crash when opening this url

Categories

(SeaMonkey :: General, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: abelloni, Unassigned)

References

()

Details

(Keywords: crash, stackwanted)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030618 Debian/1.3.1-3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030618 Debian/1.3.1-3

When opening http://members.aol.com/protanope/colorblindtest.html, all the
browser windows just close. No error messages.

Reproducible: Always

Steps to Reproduce:
1.Go at http://members.aol.com/protanope/colorblindtest.html

Actual Results:  
Mozilla crashes

Expected Results:  
Mozilla should have displayed the page correctly.

I use the default Modern theme
I have IPv6 enabled
WFM 20030614 PC/WinXP but it rendered at a ridiculously large size.  If it is
causing crashes, it's probably because of the umpteen nested <big> and <small>
tags in the code....
Well, I can't get this to work at all. I'm getting a weird error telling me it
can't handle the filetype.

What filetype is the server sending?
Please make sure that you don't have any font files that aren't world readable
in your font path.  Also, make sure you
don't have any .fon files in your path.  Also check the output of:

NSPR_LOG_MODULES=XftFontLoad:5 ./mozilla

That will give you a clue as to which font or set of fonts is causing problems.

Can you provide a 1.4RC stack trace ?

perhaps related: bug 184045, bug 192397.
Severity: major → critical
Keywords: crash, stackwanted
Summary: browser crahs when opening this url → browser crash when opening this url
If you do a 

  wget --save-headers http://members.aol.com/protanope/colorblindtest.html

I see

HTTP/1.1 200 OK
Date: Tue, 24 Jun 2003 21:00:34 GMT
Server: Apache/1.3.26 (Unix) Resin/2.0.5
Content-Length: 4438
Keep-Alive: timeout=10, max=700
Connection: Keep-Alive
Content-Type: text/html; charset=Shift_JIS,ISO-8859-1

<HTML>
<HEAD>
..etc...


Looks like moz can render a page with that charset, hence the popup.
Olivier can you actually veiw that page ?
Dave, yes, I force Mozilla to open the "application" with itself.
This is a regression, see bug 210229.
Ah ok. Lets mark this as a dup then ?
no dupe, bug 210229 is a recent regression and this works in 1.3.1
but Mozilla should not crash

marking depency (unable to test because of bug 210229)
Depends on: 210229
Mozilla isn't crashing for me.. I retried Olivier's suggestion using Mozilla
to view the "Open as" and it didn't crash for me. Reporter clear out your font
path and try again..
The URL takes me to http://colorvisiontesting.com/ which loads perfectly fine,
no crash.

Reporter, do you still see this crash? If not could you please close this bug?
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
reopening to mark WFM as no patch attached here fixed the issue.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Blocks: xft_tracking
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.