Closed Bug 210521 Opened 18 years ago Closed 12 years ago

allow semicolon-separated address list

Categories

(MailNews Core :: Composition, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 258653

People

(Reporter: smaster44, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

when receiving an email where the sender used ; as a seperator between emails,
and then I hit reply to all, write a message, and then send it, I get an error
message from mozilla.  It seems that the ; cant be used as a seperator if
mutiple email address are to be put on a single line, like under a to or a cc field.

Also, I get this problem when cuting and pasting, I whould have to cut and paste
each email address off of the line to put them all on there own line.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
I whould like to see mozilla support the ; on a to, cc or a bcc line since many
email clients do support and recignize this character.
The Internet standard (see RFC 2822 section 3.4 ,
http://www.ietf.org/rfc/rfc2822.txt) is actually a comma. The semicolon is
actually used inside the "group" syntax, but that's something else.

I know that Outlook has an option to use a comma as a separator, "to adapt to
older clients". Yeah right. You should tell your friends to switch on this
option, so that they're standards compliant.

INVALID ?
Interestingly: I just tried entering two addresses (both mine) separated with a 
semicolon, into the same To: field.  The mail was sent to both accounts without 
a problem; however, the (single) header was:
  To:  mcow@well.com;, user@domain.invalid
                    ^--- note semicolon AND comma
(If I try the same thing with a comma, I still get one header, but only the 
comma separating the two addresses.)

The semicolon is included as part of the original address, but my mail server 
doesn't mind at all.  If I reply-to-all, Mozilla creates a CC: header formatted 
exactly like the To: header.
Summary: the ";" character is not recignized in the to, cc, or bcc fields → the ";" character is not recognized in the to, cc, or bcc fields
I tried it with a semicolon, but it was refused by my mailserver - it's clearly
not a thing from Mozilla.
The mail server at our work supports receiving the ; between email address's,
because I receive email like that.
When I hit reply, and then hit send, mozilla is the one that tells me that the ;
is invalid, not my mail server.

If it was my mail server that didnt like the ; then I whouldnt have received the
email in the 1st place.

Im totally ok with mozilla massage'ing the email receipients then instead of
supporting ; and using the ; as a seperator instead.
Product: MailNews → Core
See bug 242693.

If a message arrives with semi-separated addresses, the handling on Reply-All is 
not particularly useful.  In particular, I have set up test messages following 
the same format as those in 242693.  When I Reply All, then Send (Later) and 
look at the CC: field in the sent message, the results are almost identical, and 
equally useless.

To: a@xxx.tld; b@xxx.tld
 is parsed into
CC:  "@xxx.tld; b@xxx.tld"   <- this result different from same case at 242693

To: a@xxx.tld; B <b@xxx.tld>
 is parsed into
CC: "a@xxx.tld; B" <b@xxx.tld>

To: A <a@xxx.tld>; b@xxx.tld
 is parsed into
CC: "A ; b@xxx.tld" <a@xxx.tld>

To: A <a@tld.xx>; B <b@tld.xxx>
 is parsed into
CC: "A <a@tld.xx>; B" <b@tld.xxx>


The display of these lists generally matches the way the field is parsed on 
reply (xref bug 273884), except for the first case, which appears in the 
Recipient column as:
  "\"\"a\"@xxx.tld; b@xxx.tld"
and in the envelope panel as:
  a"@xxx.tld; b@xxx.tld
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: the ";" character is not recognized in the to, cc, or bcc fields → Smarter handling of Reply All when To: contains semicolon-separated address list
*** Bug 289440 has been marked as a duplicate of this bug. ***
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: esther → composition
Product: Core → MailNews Core
Blocks: 399154
Severity: normal → enhancement
Summary: Smarter handling of Reply All when To: contains semicolon-separated address list → allow semicolon-separated address list
hmm, dup to bug 258653?
(In reply to comment #9)
> hmm, dup to bug 258653?

yes
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 258653
No longer blocks: 399154
You need to log in before you can comment on or make changes to this bug.