Cannot complete web form in some specific instances

VERIFIED WORKSFORME

Status

()

Firefox
General
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Bernard Danger, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030616 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030616 Mozilla Firebird/0.6

  I have an account on a game-swapping site, for which I am a system admin.  the
address is www.tradegamesnow.com.  As part of our service, we hook up people
that want to swap games.  We use a built-in messenger servvice that lets the
users use web forms to leave comments for each other.  When these "swaps" are
set to a "Pending" status, then ONLY THOSE pages cannot be displayed properly:
the form actually displays in the browser window TWICE, one atop the other with
a scroll bar, and the text field is unclickable.  This error DOES NOT HAPPEN IN
ANY OTHER MOZILLA BUILD, and seems limited only to Firebird.

Reproducible: Always

Steps to Reproduce:
Not sure how to reproduce, since this happens on a site requiring a login, which
I naturally don't desire to make public.  I can however send you View Source
info for the page in question if it will help you find out what characters or
code in the page is causing the error.

Actual Results:  
  Every time a page is loaded that's in "Pending" status on our site, the web
form locks.  No other types of messages, which use the same web form have this
issue.

Expected Results:  
Text should be allowed to be entered into the web form.  The browser displays
web forms from any oher status message, and IE and Mozilla both allow text to be
entered as normal.

Comment 1

15 years ago
I have not determined how to duplicate this bug happening myself, but it has
happened exactly as described below to me several times since Firebird 0.6.
Basically I'll be on a page with just a simple form. Several fields, 1 field, it
doesn't seem to matter. It seems random as far as I can tell. I click on a field
and BAM, my mouse jumps down past the end of the page, where a second copy of
the same page exists. I scroll up, and click in the first page's form field and
BAM it jumps me to the duplicate page down below. I can't type anything in the
fields either... It tends to freeze that window pretty hard sometimes too. It
happens about once every 2 days to me, and I use my browser extensively at work.
Linux, RedHat 7.3.

Most recently it happened on a SECURE page, inside a frame, but I am sure I have
seen it on non-secure non-framed pages too. I'll try to duplicate more...

Comment 2

15 years ago
I've been able to successfully duplicate the bug using the HTML code below. I've
changed "wahkas" to brackets so it'll show up on your screen rather than be
interpretted :).

If you remove the [p] OR the document.write javascript, the bug will not happen.
So I'm not sure if the [p] and the javascript are related somehow, but removing
either one makes the bug go away. If they're BOTH in the html though, the bug
happens and you see TWO copies of the form. 

Anyhow, hope this helps. It may be mis-leading, but at least it's 100%
duplicatable in my browser then I play around with it :)

[html]
[head]
[/head]
[body]
[form method="post" action="foo"]
[p]
[input type="text" ]
[input type="submit"]
[/form]

[script language="javascript"]
document.write('');
[/script]
[/body]
[/html]

Comment 3

15 years ago
Just tried to reproduce this bug with the testcase provided by Andrew, but had
no luck using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5b) Gecko/20030828
Firebird/0.6.1+

So just to make sure we all do the same things:

- I open a html-file with the provided source
- I click into the datafield and enter some text
- the text shows up as I type it

Is there anything missing? Does this problem occur every time using the provided
testcase or is it sporadic?

Finally: is this problem still reproducible using latest nightly together with a
fresh profile?

Bernard: can you reproduce your problem with the testcase provided by Andrew?

=> changing OS to all since we have Win2k and Linux & taking QA
OS: Windows 2000 → All
QA Contact: asa → mozilla

Comment 4

15 years ago
I tried the testcase code provided in Firebird 0.6.1 (Gecko/20030728) and was
not able to reproduce the bug. It must have been introduced in 0.6.0 and fixed
by 0.6.1 somehow.

Looks like it's been fixed, because when I got 0.6.0 I was able to reproduce it
with that HTML code everytime.

Guess we can either:
1) Assume it's fixed and move on, or
2) re-install an old 0.6.0 Firebird to further debug the issue and see if it was
fixed or if it's just lying dormant :)...

I vote for option 1). :) Thanks!

Comment 5

15 years ago
marking WFM as per comment 4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Hardware: PC → All
Resolution: --- → WORKSFORME

Comment 6

15 years ago
v.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

15 years ago
  Seems to be fixed in build 0.6.1.  Thank you, developers!!!  I love my
Firebird!  =)

Updated

15 years ago
Summary: Canot complete web form in some specific instances... → Cannot complete web form in some specific instances
You need to log in before you can comment on or make changes to this bug.