Pop-up window disappear on loss of focus

VERIFIED INVALID

Status

SeaMonkey
General
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: Mike Coppins, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030612

I've noticed this problem only with the 1.4 RC1 and RC2 releases, not before,
I'm fairly sure.

I have unrequested pop-up windows disabled, however on the very occasional
website, this one I've found the problem consistently on:

http://www.tombraiderchronicles.com/tng/wallpaper.html

(Apologies for the URL, what can I say, I'm a bit of a sad Tomb Raider fan)

If you left-click on one of the pictures of the downloadable wallpapers (note:
not the '1024x768' or '800x600' links, but the pictures themselves, a pop-up
window, showing a slightly bigger snapshot of the picture will be opened, as
requested.  However, if the window focus is taken from that window, and say back
to the original window, the pop-up window will disappear.


Reproducible: Always

Steps to Reproduce:
1.  Go to specified URL
2.  Click on picture of downloadable wallpapers
3.  Watch snapshot load in pop-up window
4.  click on the original window, taking the focus from the pop-up
5.  watch pop-up disappear.

Comment 1

15 years ago
NOT A BUG.
If you check the HTML Source from the pop-up window (maximize the window and
right-click out of the picture) you'll see the _body_ tag.
Check that _onblur_ (focus loss) it has a self.close(). That's why it closes.

Regards,

Manuel
(Reporter)

Comment 2

15 years ago
Oops, thanks :-)

What an odd thing to get a pop-up window to do.  Especially in this context.

Can we have an override for that? <waits to get slapped> :)

Comment 3

15 years ago
simple override-disable javascript :-)

Comment 4

15 years ago
Marking INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.