filepicker does not respect filterIndex

RESOLVED WONTFIX

Status

()

Core
XUL
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: Shane Caraveo, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

The filepicker always uses the first filter in the filter popup, even though it
shows the correct filter.  Patch to follow.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 126420 [details] [diff] [review]
fix filterIndex

may not be the best patch, but at least shows the bug.

Comment 2

15 years ago
Comment on attachment 126420 [details] [diff] [review]
fix filterIndex

>+    var fi = 0;
>+    if (typeof(o.filterIndex) != 'undefined')
>+        fi = o.filterIndex;
you could probably do this instead:
var fi = o.filterIndex || 0;
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
We still use this patch on the 1.8 branch.
(Reporter)

Comment 5

10 years ago
we stopped with this patch a long time ago, and since it's against xpfe, closing as wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.