Hitting Back to return to a form loses form data

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: sicoffey, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I fill & submit a form, then hit Back.   I'm returned to the form page, but all
my input data is lost. I would expect that my data would be preserved (and pre
1.4 (RC2 I think) it was).  I do not see this on ALL forms.  I *do* see this in
an internal website, so I can't give that as a test case unfortunately. Some
things to note about the application: the page including the form was itself the
result of a form submission.  The page generated by the form included frames ( I
recall seeing a bug mentioning this in the past, but I'm afraid I can't find  
it).  When I hit Back, I get the message about "this requires resubmitting a
POST" - so it looks like it refreshes the page each time. Also,  I had this
problem with a build of Moz about a year ago, no idea what version I'm afraid.

Reproducible: Always

Steps to Reproduce:
1. Submit form
2. Hit Back


Actual Results:  
Resulting page has form fields cleared.

Expected Results:  
Resulting page has form fields as previously filled.

Comment 1

15 years ago
This might be a duplicate of Bug 179020 (also see Bug 179330 ,  Bug 163714 ),
which would be a regression.

However I've tried the testcase attached to Bug 179020 (id=105538) and other
forms and it Works For Me on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4)
Gecko/20030612
(Reporter)

Comment 2

15 years ago
Tested again today, same build as before. Problem now not present on the very
same form. I guess I'll say its "fixed" for now! - until it comes back, if ever...
worksforme, per reporter in comment 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.