Last Comment Bug 210614 - filters on a pop account cannot transfer items to an imap account
: filters on a pop account cannot transfer items to an imap account
Status: RESOLVED FIXED
: fixed-aviary1.0
Product: MailNews Core
Classification: Components
Component: Filters (show other bugs)
: Trunk
: x86 Windows NT
: -- major with 1 vote (vote)
: ---
Assigned To: David :Bienvenu
: laurel
Mentors:
: 66391 180094 253072 267267 268493 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-25 04:21 PDT by Marcus Streets
Modified: 2008-07-31 01:22 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (6.75 KB, patch)
2004-11-18 10:36 PST, David :Bienvenu
mscott: superreview+
Details | Diff | Splinter Review

Description Marcus Streets 2003-06-25 04:21:16 PDT
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5a) Gecko/20030619 Mozilla Firebird/0.6
Build Identifier: Mozilla Thunderbird 0.1a 920030616)

If you have a mix of pop and imap accounts and you set up a fiulter on a pop
account to transfer incoming mail to a folder on an imap account it fails with
the error

"The message could not be filtered to folder 'xxxx' because another operation is
in progress.

Note - if you run the filter manually using the run now button from the filters
dialog box it works correctly.

I suspect that the pop download grabs a lock and the filters run before the lock
is released.  I guess that you want to complete the pop download and release the
lock before starting to run the enabled filter on the downloaded messages.

Reproducible: Always

Steps to Reproduce:
1. set up a pop and imap account
2. set up a mail filter on pop account filtering mails with test in supbject
line to a folder on the imap account
3. send your pop accouint a mail called test

Actual Results:  
I get the message listed in details

Expected Results:  
Message should be filtered correctly.
Comment 1 Mike Cowperthwaite 2003-12-17 09:54:20 PST
This might be a dupe of bug 168648, but I'm not sure, since the target here is 
an IMAP (remote) folder.
Comment 2 Marcel van Erk 2004-07-25 08:50:02 PDT
To bad this has never been addressed yet.

Reproduced it on Mozilla 1.7 and Thunderbird 0.7.1

Hope this gets fixed. 

Comment 3 Mike Cowperthwaite 2004-07-28 04:16:06 PDT
See also bug 180094.
Comment 4 Mike Cowperthwaite 2004-08-26 11:38:24 PDT
*** Bug 253072 has been marked as a duplicate of this bug. ***
Comment 5 Mike Cowperthwaite 2004-08-26 11:56:35 PDT
Argh.  Bug 66391 has morphed from: 
"Mail is lost when filtering to an IMAP folder" (bug 180094), to:
"Pop3 msg filters shouldn't allow move to imap folder" (disallow this option in 
the UI), to:
"Mail filters should allow moving mail from local folders and POP inboxes to 
imap folders" which is being described as "an enhancement" altho the bug is 
still rated "major."

THIS bug, as it stands, is about the fact that the UI allows it, but it doesn't 
work.

However, if I manually run the filter on the POP folder, the message gets moved 
as expected (with no dataloss in my limited testing).

Getting these bugs properly resolved is better left to a developer who knows 
what's what.
Comment 6 Mike Cowperthwaite 2004-11-02 10:00:07 PST
*** Bug 267267 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Versen [:Matti] 2004-11-17 08:47:06 PST
confirming based on a user asking on IRC for help with for the same reason...
Comment 8 David :Bienvenu 2004-11-18 10:36:28 PST
Created attachment 166345 [details] [diff] [review]
proposed fix

also, I needed to move the source files around in the cvs repository, from
imap/src to base/util - I kept the name as nsImapMoveCoalescer since it's main
use is for coalescing imap moves...
Comment 9 Mikhail Ramendik 2004-11-20 08:56:11 PST
I have tested the 2004-11-20-06-trunk nightly build and the bug is still there, 
although it looks diferently. The filter directed to an IMAP folder is silently 
skipped, with even no notice to the filter log. (I also included another filter 
to a non-IMAP folder and trhat one worked fine on teh same mail receiving). 
Comment 10 sairuh (rarely reading bugmail) 2004-11-22 22:26:27 PST
hm, somehow this was moved into the wrong product/component (prolly weirdness
due to the bugzilla restructure).

anyhow, I had tested with 2004112207-0.9 tbird bits on WinXP, and this now works
with incoming mail, as well as when I click "Run Now" from the Message Filters
dialog.

however, this doesn't seem to work when I select Tools > Run Filters on Folders
from the main menu. (doesn't matter if focus is on the folder in the folder
pane, or in the thread pane.) is there another bug for that, though?
Comment 11 David :Bienvenu 2004-11-23 07:50:43 PST
I don't know if there is a bug on the run filters on Folders aspect - but if
not, it should be a separate bug since the code is separate...
Comment 12 David :Bienvenu 2004-11-23 08:02:59 PST
*** Bug 180094 has been marked as a duplicate of this bug. ***
Comment 13 J. Bøckman 2005-02-01 08:06:31 PST
*** Bug 268493 has been marked as a duplicate of this bug. ***
Comment 14 Mike Cowperthwaite 2005-03-02 10:25:55 PST
*** Bug 66391 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.