Minimum frame time set to 100 milliseconds CONTRARY to GIF89a standard!

RESOLVED DUPLICATE of bug 125137

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 125137
15 years ago
4 years ago

People

(Reporter: Dr. Rolf Schroeder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4a) Gecko/20030401

The GIF89a-Standard allows to set the frame , i.e. 20 milliseconds to achive
movie like effects. Claimind that Mozilla has to follow Microsoft's IE is not
understood by me, for then I could use IE, no need to use Mozilla!
Solution: under 'media' introduce a switch to set the minimum frame time and set
the default to 100 milliseconds. So, Mozilla could be set to keep the GIF89a
standard!
OPERA keeps the GIF89a standard, Mozilla should not help M$ to destroy it!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
To be able to display GIF's as they should, i.e., frame times less then 100 ms.

The GIF89a standard is given here:

ftp://ftp.ncsa.uiuc.edu/misc/file.formats/graphics.formats/gif89a.doc .

By the way: since June 20th 2003, the GIF89a license is free!

Comment 1

15 years ago
We know. That's to be compatible with Internet Exploder (PC-version, Mac IE is
ok). If we would fix this, then people would complain that we display their gifs
too fast.

Hang on, I'm looking for a good bug to dupe this again (there was a clever
proposition somewhere).

Comment 2

15 years ago
The reason of the 100 msec delay is bug 125137. See also bug 139677 (Mac doesn't
need minimum frame delay) and bug 71829 (let user specify a minimum delay for
anims that don't have one).

Comment 3

15 years ago
Would someone with the proper privledges please dupe this against bug 125137 per
comment #2, so it can stop cluttering Browser-General? Or at least mark VERIFIED
WONTFIX if that is the consensus. Thanks.

Comment 4

15 years ago
I realize this is a hot issue, but it's also definitely a dupe of bug 125137.
There's nothing "false" about 125137. Please take any comments over there so
this discussion can be kept in one place rather than fragment across multiple
bugs, unless someone feels this is *definitely* a different issue than the
multiple other bugs relating to animated gif speed are about. Thank you.

*** This bug has been marked as a duplicate of 125137 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.