Closed Bug 210663 Opened 17 years ago Closed 15 years ago

Argument "" isn't numeric in numeric gt (>) at data/template/en/default/global/hidden-fields.html.tmpl line 43

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

2.17.4
defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 2.20

People

(Reporter: justdave, Assigned: wicked)

References

Details

I keep seeing this in the logs on Bugscape:

Argument "" isn't numeric in numeric gt (>) at
data/template/en/default/global/hidden-fields.html.tmpl

Line 43 of the compiled template is:

    if ($stash->get(['mform', 0, $stash->get(['field', 0, 'key', 0]), 0, 'size',
0]) > 1) {

which appears to be generated by this line in hidden-fields.html.tmpl:

  [% IF mform.${field.key}.size > 1 %]

Is this a bug in TT?  My only guess is maybe for some reason field.key isn't
defined that time through the loop or something.  It usually appears in groups -
I'll get two or three of them at once with the same timestamp on the logs.
Are there always entries in MFORM for FORM stuff? When people do |if
($::FORM{foo}) { ... }|, that won't create an element in MFORM, remember. You
should probably have a |[% NEXT UNLESS field.value.defined %]| (Is it .value?),
and/or test mform.${field.key}.exists first.
*** Bug 190208 has been marked as a duplicate of this bug. ***
I think when the hidden fields template gets converted to using the CGI stuff
(see bug 225818 and dependencies) this might go away.
Depends on: 225818
Depends on: 238878
No longer depends on: 225818
fixed by bug 238878
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.20
Assignee: myk → wicked+bz
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.