Add prefs for text formatting

VERIFIED DUPLICATE of bug 21649

Status

P3
normal
VERIFIED DUPLICATE of bug 21649
19 years ago
11 years ago

People

(Reporter: scalkins, Assigned: BenB)

Tracking

Trunk
Other
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Saw this on Linux and Mac builds 1999-12-07-08 M12

Steps to reproduce:
1)Launch Seamonkey and login to Mail via Tasks-->Mail
2)Compose a message to yourself, but enclose a few of the words on one line in
asterisks for example:
This is *a simple test* of this case.
3)Send the message, then view it on a seamonkey Mail client.(Or on Netscape 4.7
mail)

Actual results: Text enclosed in asterisks is bolded.

Expected results: Expect same behavior as Netscape 4.7, where everything shows
as normal text.

Notes:
Does not occur to text surrounded by asterisks if there is a hard carriage
return between the asterisks. However, if you type an asterisk, and as you type
more text it wraps to the next line in mail compose,& another asterisk is typed,
all enclosed text will be bolded.
 Putting asterisks around text in Composer does not insert HTML tags for bolding
text. It seems to only be put there by Mail Compose.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → pmock
(Reporter)

Updated

19 years ago
OS: Linux → All

Comment 1

19 years ago
Is this in plain text?  I think this is expected behavior due to bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=16507

mozilla@bucksch.org - is there a way to turn this pref off?
(Assignee)

Updated

19 years ago
Assignee: ducarroz → mozilla
Summary: Asterisks around words cause enclosed word to be seen in BOLD print → Add prefs for text formatting
(Assignee)

Comment 2

19 years ago
Chaning Summary from "Asterisks around words cause enclosed word to be seen in
BOLD print" to add prefs for text formatting.

Scalkins: It is tradition to emphazies word / pharses with stars. See bug
#16507.

lchiang: thanks for notice.
No, we don't have prefs yet, the callers must add them. I'll take a look at
prefs.
(Assignee)

Comment 3

19 years ago
Scalkins: do you have a case, where you don't want this formatting (I guess so)?
(Reporter)

Comment 4

19 years ago
My concern with it was that if you have an asterisk in two different places of
your text (to denote a "Footnote" maybe?)and the text was wrapped in mail
compose between them, all text between these asterisks may be bolded (Paragraphs
worth maybe). Also Composer does not but these tags there for asterisks around
words,
(Reporter)

Comment 5

19 years ago
To clarify a bit more:  What I meant was, if I type in mail compose the
following sentence:

This is a *very long sentence which runs on and on and wraps and wraps to the
*next line again and again

All the text between the two asterisks in the sentence above are bolded because
of this bug.
(Assignee)

Comment 6

19 years ago
scalkins,
should not be changed with todays build.

"We're searching for the following pattern:
LT_DELIMITER - "*" - ALPHA -
[ some text (maybe more "*"-pairs) - ALPHA ] "*" - LT_DELIMITER.
<strong> is only inserted, if existance of a pair could be verified
We use the first opening/closing tag, if we can choose"
(<http://lxr.mozilla.org/seamonkey/source/netwerk/streamconv/converters/mozTXTToHTMLConv.cpp#522>)

The scope depends on the caller: the pattern must match for the string passed
to ScanHTML/-TXT.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

19 years ago
*** This bug has been marked as a duplicate of 21649 ***

Comment 8

19 years ago
Shouldn't the other bug (which is filed later) be made a duplicate of this one?
:-)
(Assignee)

Comment 9

19 years ago
Lisa, I guess, you know, why it is that way :-).

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
verified as duplicate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.