Container DIV does not resize when a child DIV is set to Float

RESOLVED INVALID

Status

()

Core
Layout: Floats
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Dwight Brown, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

You can see the #nav (float: left;) and #content (float: right;) appear
-outside- the bounds of the parent div tag.

The parent div tag is not resizing to correctly contain the floating child div tags.

The desired result is produced by IE6, fyi.

Reproducible: Always

Steps to Reproduce:
1. Create a DIV
2. Withing that DIV create a child DIV
3. Set the child DIV to float left or right

Actual Results:  
The parent DIV does not resize to include the size of the floating child DIV

Expected Results:  
The parent should resize to include the size of the child DIV
Blocks are not supposed to resize to contain overflowing floats.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

14 years ago
*** Bug 272771 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
(In reply to comment #1)
> Blocks are not supposed to resize to contain overflowing floats.

I don't believe this is true.
See the lengthy discussion on bug 209694.
It is true. You must be misunderstanding the discussion in bug 209694 (and I
don't blame you, because the discussion there is extremely complex...)

Comment 5

13 years ago
*** Bug 285721 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.