browser crash when removing child div of a form [@ nsHTMLButtonElement::HandleDOMEvent ]

RESOLVED DUPLICATE of bug 194582

Status

()

Core
DOM: Events
--
critical
RESOLVED DUPLICATE of bug 194582
15 years ago
15 years ago

People

(Reporter: Raphael Bauduin, Assigned: saari (gone))

Tracking

({crash, testcase})

Trunk
x86
Linux
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030625
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030625

When clicking on the button on the page
http://www.raphinou.com/removeFormChild.html, the onclick event triggers a
removeChild that is intended to remove the div in which the button is placed.
This div is the child of a form. When the div is not child of a form, there is
no problem. When the div is child of a form element, it crashes with the latest
browsers (mozilla firebird and mozilla nightly builds). With Mozilla 1.2.1 it
works correctly.

Reproducible: Always

Steps to Reproduce:
1.clock on the button "remove this div"
2.
3.

Actual Results:  
crash

Expected Results:  
delete the div the button is a child of

Comment 1

15 years ago
can you post Talkback ID or GDB stack trace for this crash ?
Keywords: crash, stackwanted, testcase

Comment 2

15 years ago
Created attachment 126549 [details]
Stack trace on Linux

Comment 3

15 years ago
Talkback: TB21372952Y
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: TB21372952Y

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 194582 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Summary: browser crash when removing child div of a form → browser crash when removing child div of a form [@ nsHTMLButtonElement::HandleDOMEvent ]
Whiteboard: TB21372952Y
Crash Signature: [@ nsHTMLButtonElement::HandleDOMEvent ]
You need to log in before you can comment on or make changes to this bug.