If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attempt to create activex browser object causes application to hang

RESOLVED DUPLICATE of bug 190181

Status

Core Graveyard
Embedding: ActiveX Wrapper
RESOLVED DUPLICATE of bug 190181
14 years ago
6 years ago

People

(Reporter: William Parke, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows) version 1.4 RC2 (mozctlx.dll 1.4.20030.61205)

Installed Mozilla 1.4 RC2 to default directory in Windows 2000. Registered 
mozctlx.dll (version 1.4.20030.61205). Attempt to create browser object with 
above test URL causes IE to hang. Also attempt to create activex object on Form 
in APL+Win/APL2000 causes APL session to hang. Task Manager required to 
terminate applications in each instance. Reproducible every time, on two 
different machines.
Uninstalled above version and installed version 1.3.1 and registered its DLL 
(version 1.3.20030.42512). Now able to create Mozilla Browser objects in IE and 
in APL+Win.
Note also tried this with Netscape 7.02 (mozctlx.dll version 1.0.2.0) and 
recevied unidentified fatal error in IE, "unable to read memory address..." 
type fatal error in APL+Win.

Reproducible: Always

Steps to Reproduce:
1.Install Mozilla 1.4 RC2 on Windows 2000
2.Register mozctlx.dll
3.Use test URL page http://www.iol.ie/~locka/mozilla/mozctltest1.htm in IE or 
create object in APL+Win

Actual Results:  
applications hang, must use Windows Task Manager to end

Expected Results:  
successful object creation as in version 1.3.1
(Assignee)

Comment 1

14 years ago
See bug 190181 for analysis and workaround. The short version is the GRE dir
doesn't contain any chrome or res files and when the control loads, Gecko is
stuck in some infinite loop because of this.

*** This bug has been marked as a duplicate of 190181 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.