Java plug-in crashes browser after logging in to 1822direkt.com

RESOLVED FIXED

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: Oliver Klee, Assigned: Kyle Yuan)

Tracking

({relnote})

Trunk
x86
All
relnote

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 from CVS, built on 2003-06-23

After having logged in at https://www.1822direkt.com/ , the browser crashes.

Other applet run flawless.

Java version:
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2-b28)
Java HotSpot(TM) Client VM (build 1.4.2-b28, mixed mode)

Using /usr/java/j2sdk1.4.2/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

JRE 1.4.1_01-b01 doesn't have this problem.

The same problem occurs with Mozilla 1.3.

Reproducible: Always

Steps to Reproduce:
(you need an account at 1822direkt.com for this, the demo account doesn't show
this problem)

1. https://www.1822direkt.com/onlineb.window_follow.html
2. Move the mouse until the login screen is shown
3. enter customer id and PID
4. press enter

Actual Results:  
The browser crashes

Expected Results:  
no crash, the usual bank account management dialog is shown

The Java Console shows:

Using www.1822direkt.com
>direkt1822.ib100.Registrate< loaded.
>direkt1822.ib100.AccountOverview< loaded.
>direkt1822.ib100.Feedback< loaded.
>direkt1822.ib100.AccountOrders< loaded.
>direkt1822.ib100.TurnOver< loaded.
>direkt1822.ib100.PinTanAdmin< loaded.
>direkt1822.ib100.Depot< loaded.
>direkt1822.ib100.Transfer< loaded.
>direkt1822.ib100.StockTrade< loaded.
>direkt1822.ib100.DirectTrade< loaded.
>direkt1822.ib100.Subscription< loaded.
>direkt1822.ib100.ForeignExchange< loaded.
>direkt1822.ib100.StandingOrders< loaded.
>direkt1822.ib100.StOrderEdit< loaded.
>direkt1822.ib100.OrderSearch< loaded.
>direkt1822.ib100.Randomizer< loaded.
>direkt1822.ib100.Invest< loaded.
>direkt1822.ib100.Note< loaded.
>direkt1822.ib100.WPOrderSearch< loaded.
All classes are loaded.
(Reporter)

Comment 1

15 years ago
BTW, I reported this problem to 1822direkt and Sun as well as I am not really
sure who's to blame.

Comment 2

15 years ago
I have bug #211003 with a very similar problem with Sparkasse Karlsruhe.
Can you start Mozilla with -g on a commandline to look if the message is
the same ? That output implies that it is a severe browser regression, and
if this breaks all internet banking it should be fixed very soon because
of high impact.
(Reporter)

Comment 3

15 years ago
I didn't manage to successfully start my Mozilla debug build with -g (got some
error message before the main window came up), but this is what I get at the
console when starting my debug build without -g:

Document http://www.mozilla.org/start/ loaded successfully
WARNING: CreateSecureEnv OK, file ProxyJNI.cpp, line 1676
For application/x-java-vm found plugin
/usr/java/j2sdk1.4.2/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
Document https://www.1822direkt.com/onlineb.window_follow.html loaded successfully
###!!! ASSERTION: OnDataAvailable implementation consumed no data: 'Error', file
nsInputStreamPump.cpp, line 436
Break: at file nsInputStreamPump.cpp, line 436
###!!! ASSERTION: OnDataAvailable implementation consumed no data: 'Error', file
nsInputStreamPump.cpp, line 436
Break: at file nsInputStreamPump.cpp, line 436
INTERNAL ERROR on Browser End: Plugin instance index out of bounds 13632

System error?:: Die Ressource ist zur Zeit nicht verfügbar

Comment 4

15 years ago
Confirming on Windows XP and Windows 2K

Other test site:
http://www.fauxs-x.com

Try to browse "DesktopX" with Java 1.4.2 (release version). System will be very
slow and eventually "hang".

Changing OS to "all".

Blocker for 1.4?
OS: Linux → All
(Reporter)

Comment 5

15 years ago
Requesting as 1.4 blocker - if the Mozilla.org Linux builds are compiled with
gcc3.2, there is no JRE by Sun that works with Mozilla 1.4 on Linux:

- JRE 1.4.1 does not have a gcc3.2 version

- JRE 1.4.2 has a gcc3.2 version, but does not work for online banking

I still haven't gotten the IBM JRE to work, either (but maybe I have just
installed the IBM JRE the wrong way).
Flags: blocking1.4?
(Reporter)

Comment 6

15 years ago
cc:ing Asa because of the blocker request.

Comment 7

15 years ago
*** Bug 211003 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
Also voting for a blocker, since 1.4 is some kind of 'final' version of Mozilla.

Comment 9

15 years ago
"INTERNAL ERROR on Browser End: Plugin instance index out of bounds 13632
System error?:: Die Ressource ist zur Zeit nicht verfügbar"

This is error report from JPI side, I try to reproduce this bug.

"JRE 1.4.1_01-b01 doesn't have this problem.
JRE 1.4.2 has this problem.
The same problem occurs with Mozilla 1.3"

so it maybe jre1.4.2 's problem.
Status: NEW → ASSIGNED

Comment 10

15 years ago
can you provide an account for testing?
I can't login.

Thanks!

Comment 11

15 years ago
Plugin: JavaVM5 Obtained next work code code F60004
Plugin: JavaPluginFactory5:GetInstance
Plugin: JavaPluginFactory trying to enter GetInstance
Plugin: JavaPluginFactory Entered GetInstance
Plugin: Chose random instance 0
Plugin: JavaPluginFactory exiting GetInstance-any
Plugin: JavaVM5 GetPluginFactory
Plugin: CookieSupport reply for an original JAVA_PLUGIN_COOKIE_REQUEST
Plugin: JavaPluginFactory trying to enter SendRequest
Plugin: JavaPluginFactory Entered SendRequest
Plugin: JavaVM5 Sending command 
Plugin: JavaVM5 SendRequest: Wrote request. No reply needed.
Plugin: JavaPluginFactory exiting SendRequest-noreply
Plugin: JavaVM5 Doing work
Plugin: JavaVM5 No work on work pipe
Plugin: JavaVM5 Done with processing work queue
Plugin: QueueRunnable: Posting Event: pipe 40 activity
Plugin: JavaVM5 In worker event handler
Plugin: JavaVM5 ProcessWorkQueue
Plugin: JavaVM5 Doing work
Plugin: JavaVM5 Obtained next work code code 44353939
Plugin: JavaPluginFactory5:GetInstance
Plugin: JavaPluginFactory trying to enter GetInstance
Plugin: JavaPluginFactory Entered GetInstance


"Plugin: JavaVM5 Obtained next work code code 44353939" is abnormal

Comment 12

15 years ago
Try also https://homebanking.dvg-ka.de/055/index.html, (invalid) account
1234567890, pass 12345.

Comment 13

15 years ago
Bad ! 1.4 is out now without internet banking ! Need blocking 1.4.1 or whatever
comes next.
(Reporter)

Updated

15 years ago
Keywords: relnote

Comment 14

15 years ago
This should be Java Plugin 's bug,
so it don't block mozilla.
Flags: blocking1.4?
(Reporter)

Comment 15

15 years ago
*** Bug 214183 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
Not working on 1.5alpha i686 Linux either, supporting plugin bug theory...
Any news or progress from Sun ?

Comment 17

15 years ago
Just tried ns4 plugin 1.4.2 with Netscape 4.79, and it does NOT crash.
So either only ns610 is broken, or it's even a bug in the browser, as the line 
'INTERNAL ERROR on Browser End' suggests...

Comment 18

15 years ago
Tried with new java plugin 1.4.2_01 today. Still crashes with the same symptom...

Comment 19

15 years ago
Tried with new 1.5b release, gcc-2.95.3 compiled, ns610 plugin. Still crashing.
Has this bug been filed at Sun ? I cannot find a matching entry in the plugin
bugparade.

Comment 20

15 years ago
Which version of JRE are you trying?
(Reporter)

Comment 21

15 years ago
Beanladen, this entry has been filed at the Sun Bug Parade, but I can't find it
either. Maybe the folks at Sun only publish confirmed bug reports.

Comment 22

15 years ago
This whole bug and all of it duplicates is about 1.4.2 and higher.
As I reported yesterday, also the new release 1.4.2_01 are affected.
All versions below 1.4.2 work, and my comment #17 also states that
the ns4 version of all 1.4.2 releases work with netscape 4.x.

Comment 23

14 years ago
i have experienced this bug as well, but here's a workaround i discovered today:
use blackdown.org's j2re-1.4.1-01-linux-i586-gcc3.2.bin . works like a charm.

Comment 24

14 years ago
Since nothing seems to happen here, I reported that bug to Sun again, hoping that
a duplicate will trigger something. Instead, they determined that this is a new
bug, so the old report from Oliver seems to be lost. The new bug ID is 4937393 
and will appear at
http://developer.java.sun.com/developer/bugParade/bugs/4937393.html

Comment 25

14 years ago
the bug mentioned in comment #23 has been duplicated against a fixed bug:
"It is a duplicate of [
http://developer.java.sun.com/developer/bugParade/bugs/4935740.html ]. It is
going to be fixed in 1.4.2_03."

Comment 26

14 years ago
*** Bug 226117 has been marked as a duplicate of this bug. ***

Comment 27

14 years ago
->kyle
Assignee: joshua.xia → kyle.yuan
Status: ASSIGNED → NEW

Comment 28

14 years ago
Java 1.4.2_03 is out, but bug was not fixed. Rescheduled for 1.4.2_04.

Comment 29

14 years ago
It has been fixed in 1.4.2_04 and 1.5 release.

Comment 30

14 years ago
*** Bug 228443 has been marked as a duplicate of this bug. ***

Comment 31

14 years ago
Tried java 1.4.2_04 Linux i686. Bug is verified fixed.
(Reporter)

Comment 32

14 years ago
Also tried Java 1.5 beta 1 on Linux: Works was well. Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 33

14 years ago
A very closed bug concerning a different applet with Mozilla 1.3.1 has been
solved with jre 1.4.2_04 too.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.