Crash while printing www.stern.de [@ nsIFrame::SetNextSibling]

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
critical
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Roland Mainz, Unassigned)

Tracking

({crash})

Trunk
Sun
Solaris
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
2003-06-14-08-trunk_cvs and 1.4rc3 on Solaris/SPARC, Zilla crashes like this
when printing http://www.stern.de/
-- snip --
WARNING: empty damage rect: update caller to avoid fcn call overhead, file
../../../../../src/mozilla/layout/html/base/src/nsFrame.cpp, line 2686
WARNING: empty damage rect: update caller to avoid fcn call overhead, file
../../../../../src/mozilla/layout/html/base/src/nsFrame.cpp, line 2686
###!!! ASSERTION: Registering a placeholder for a frame that already has a
placeholder!: '!entry->placeholderFrame', file
../../../../../src/mozilla/layout/html/base/src/nsFrameManager.cpp, line 772
Break: at file
../../../../../src/mozilla/layout/html/base/src/nsFrameManager.cpp, line 772
###!!! ASSERTION: Registering a placeholder for a frame that already has a
placeholder!: '!entry->placeholderFrame', file
../../../../../src/mozilla/layout/html/base/src/nsFrameManager.cpp, line 772
Break: at file
../../../../../src/mozilla/layout/html/base/src/nsFrameManager.cpp, line 772
WARNING: empty damage rect: update caller to avoid fcn call overhead, file
../../../../../src/mozilla/layout/html/base/src/nsFrame.cpp, line 2686
###!!! ASSERTION: bad push: 'overBegin != begin_lines()', file
../../../../../src/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 4378
Break: at file ../../../../../src/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 4378
###!!! ASSERTION: running past end: 'mCurrent != mListLink', file
../../../../../src/mozilla/layout/html/base/src/nsLineBox.h, line 546
Break: at file ../../../../../src/mozilla/layout/html/base/src/nsLineBox.h, line
546
t@1 (l@1) signal SEGV (no mapping at the fault address) in
nsIFrame::SetNextSibling dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsBlockFrame.o"
dbx: warning: see `help finding-files'
at 0xfa43b5ac
0xfa43b5ac: SetNextSibling+0x0034:      st      %l1, [%l0 + 0x20]
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsBlockReflowContext.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsBlockReflowState.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsLineLayout.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsContainerFrame.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsPageContentFrame.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsPageFrame.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsSimplePageSequence.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsViewportFrame.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsPresShell.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/layout/build/nsPrintEngine.o"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/embedding/components/build/nsPrintProgress.o"
Current function is XPCWrappedNative::CallMethod
 2016           invokeResult = XPTC_InvokeByIndex(callee, vtblIndex,
(dbx) where
current thread: t@1
  [1] nsIFrame::SetNextSibling(0x0, 0x0, 0xc62678, 0xffbe8ac4, 0xffbe8abc, 0x8),
at 0xfa43b5ac
  [2] nsBlockFrame::PushLines(0xeb4258, 0xffbe9ae8, 0xffbe8b5c, 0x0, 0xffbe8b60,
0xffbe8d71), at 0xfa42cf1c
  [3] nsBlockFrame::PushTruncatedPlaceholderLine(0xeb4258, 0xffbe9ae8,
0xffbe8c08, 0x0, 0xffbe961c, 0xffbe8c4b), at 0xfa429f0c
  [4] nsBlockFrame::DoReflowInlineFrames(0xeb4258, 0xffbe9ae8, 0xffbe8cfc,
0xffbe8cf0, 0xffbe961c, 0xffbe91cb), at 0xfa42a484
  [5] nsBlockFrame::DoReflowInlineFramesAuto(0x0, 0xffbe9ae8, 0xffbe91b8,
0xffbe961c, 0xffbe91cb, 0x0), at 0xfa429dec
  [6] nsBlockFrame::ReflowInlineFrames(0xeb4258, 0xffbe9ae8, 0xffbe92fc,
0xffbe961c, 0x0, 0x0), at 0xfa429a14
  [7] nsBlockFrame::ReflowLine(0xeb4258, 0xffbe9ae8, 0xffbe95a0, 0xffbe961c,
0x0, 0xd59bb8), at 0xfa426b40
  [8] nsBlockFrame::ReflowDirtyLines(0xeb4258, 0xffbe9ae8, 0xa17b90, 0xeb4258,
0xffbe9ff0, 0x400000), at 0xfa42568c
  [9] nsBlockFrame::Reflow(0xffbe9ff0, 0xa17b90, 0xffbe9ff0, 0xffbea050,
0xffbea8cc, 0x0), at 0xfa420f98
  [10] nsBlockReflowContext::ReflowBlock(0xffbe9fac, 0xffbea108, 0x1,
0xffbe9fa0, 0x1, 0xc08390), at 0xfa442e88
  [11] nsBlockFrame::ReflowFloater(0xffbea050, 0xffbeb850, 0xeb42ac, 0xc08378,
0xffbea8cc, 0x50), at 0xfa43002c
  [12] nsBlockReflowState::FlowAndPlaceFloater(0xffbeb850, 0xc08378, 0xffbea3e0,
0xffbea8cc, 0x0, 0x0), at 0xfa448ab4
  [13] nsBlockReflowState::AddFloater(0xffbeb850, 0xffbeaa64, 0xeb42ac, 0x0,
0xffbea8cc, 0xffbea8cc), at 0xfa448404
  [14] nsLineLayout::AddFloater(0xffbeaa64, 0xeb42ac, 0xffbea8cc, 0xffbea6c0,
0xffbea8cc, 0x2610), at 0xfa528d14
  [15] nsLineLayout::ReflowFrame(0x2610, 0xeb42ac, 0xffbea8cc, 0x0, 0xffbea8c8,
0xffbeaad9), at 0xfa5203ec
  [16] nsBlockFrame::ReflowInlineFrame(0xeb863c, 0xffbeb850, 0xffbeaa64,
0xffbea988, 0xeb42ac, 0xffbea9b3), at 0xfa42a8e8
  [17] nsBlockFrame::DoReflowInlineFrames(0xeb863c, 0xffbeb850, 0xffbeaa64,
0xffbeaa58, 0xffbeb384, 0xffbeaf33), at 0xfa42a2b0
  [18] nsBlockFrame::DoReflowInlineFramesAuto(0x0, 0xffbeb850, 0xffbeaf20,
0xffbeb384, 0xffbeaf33, 0x0), at 0xfa429dec
  [19] nsBlockFrame::ReflowInlineFrames(0xeb863c, 0xffbeb850, 0xffbeb064,
0xffbeb384, 0x0, 0x0), at 0xfa429a14
  [20] nsBlockFrame::ReflowLine(0xeb863c, 0xffbeb850, 0xffbeb308, 0xffbeb384,
0x0, 0x2610), at 0xfa426b40
  [21] nsBlockFrame::ReflowDirtyLines(0xeb863c, 0xffbeb850, 0xa17b90, 0xeb863c,
0xffbec1ec, 0x400000), at 0xfa42568c
  [22] nsBlockFrame::Reflow(0xffbec1ec, 0xa17b90, 0xffbec1ec, 0xffbebb44,
0xffbec0d4, 0x0), at 0xfa420f98
  [23] nsContainerFrame::ReflowChild(0xeb85e8, 0xeb863c, 0xa17b90, 0xffbec1ec,
0xffbebb44, 0x0), at 0xfa4622d8
  [24] nsPageContentFrame::Reflow(0xeb85e8, 0xa17b90, 0xffbec1ec, 0xffbebd8c,
0xffbec0d4, 0x0), at 0xfa56c2e0
  [25] nsContainerFrame::ReflowChild(0xeb857c, 0xeb85e8, 0xa17b90, 0xffbec1ec,
0xffbebd8c, 0x2d0), at 0xfa4622d8
  [26] nsPageFrame::Reflow(0x2d0, 0xa17b90, 0xffbec1ec, 0xffbec0d8, 0xffbec0d4,
0x0), at 0xfa562630
  [27] nsContainerFrame::ReflowChild(0xd68cb8, 0xeb857c, 0xa17b90, 0xffbec1ec,
0xffbec0d8, 0x0), at 0xfa4622d8
  [28] nsSimplePageSequenceFrame::Reflow(0x405a, 0xa17b90, 0xffbec64c,
0xffbec58c, 0xffbec9a8, 0x0), at 0xfa5c4e80
  [29] nsContainerFrame::ReflowChild(0xd68ba8, 0xd68cb8, 0xa17b90, 0xffbec64c,
0xffbec58c, 0x0), at 0xfa4622d8
  [30] ViewportFrame::Reflow(0xd68ba8, 0xa17b90, 0xffbec9ac, 0xffbec8e8,
0xffbec9a8, 0xffbec9f8), at 0xfa6026b0
  [31] PresShell::InitialReflow(0xa23198, 0x2bb0, 0x3ef2, 0x2bb0, 0x3ef2, 0x2),
at 0xfa57bbf0
  [32] nsPrintEngine::ReflowPrintObject(0xa7b938, 0x9e28d8, 0x1, 0x0, 0x0, 0x0),
at 0xfa9b45e0
  [33] nsPrintEngine::ReflowDocList(0xa7b938, 0x9e28d8, 0x0, 0x1, 0x0, 0x0), at
0xfa9b2a90
  [34] nsPrintEngine::SetupToPrintContent(0xa7b938, 0xa58560, 0x0, 0xff3e4270,
0xfa100a66, 0xd85), at 0xfa9b1ed4
  [35] nsPrintEngine::DocumentReadyForPrinting(0xa7b938, 0x19cb88, 0xffbed1a8,
0xffbecf30, 0x1, 0x0), at 0xfa9afba0
  [36] nsPrintEngine::Observe(0xa7b938, 0x0, 0x0, 0x0, 0x0, 0xbb03b1), at
0xfa9bc7b0
  [37] nsPrintProgress::DoneIniting(0xc06c00, 0x6, 0xffbed5b0, 0xd39bd8,
0xd322f8, 0xc06c04), at 0xf9d48aa8
  [38] XPTC_InvokeByIndex(0xc06c00, 0xc, 0x0, 0xffbed658, 0xd322f8, 0xc06c04),
at 0xfdb91ea8
=>[39] XPCWrappedNative::CallMethod(ccx = CLASS, mode = CALL_METHOD), line 2016
in "xpcwrappednative.cpp"
  [40] XPC_WN_CallMethod(cx = 0xd39bd8, obj = 0xd322f8, argc = 0, argv =
0xa42bcc, vp = 0xffbed938), line 1269 in "xpcwrappednativejsops.cpp"
  [41] js_Invoke(cx = 0xd39bd8, argc = 0, flags = 0), line 843 in "jsinterp.c"
  [42] js_Interpret(cx = 0xd39bd8, result = 0xffbee304), line 2854 in
"jsinterp.c"
  [43] js_Invoke(cx = 0xd39bd8, argc = 1U, flags = 2U), line 860 in "jsinterp.c"
  [44] js_InternalInvoke(cx = 0xd39bd8, obj = 0xd323e0, fval = 13838376, flags =
0, argc = 1U, argv = 0x6eb6d0, rval = 0xffbee54c), line 935 in "jsinterp.c"
  [45] JS_CallFunctionValue(cx = 0xd39bd8, obj = 0xd323e0, fval = 13838376, argc
= 1U, argv = 0x6eb6d0, rval = 0xffbee54c), line 3531 in "jsapi.c"
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/dom/src/build/nsJSEnvironment.o"
  [46] nsJSContext::CallEventHandler(0xd35750, 0xd323e0, 0xd32828, 0x1,
0x6eb6d0, 0xffbee6c0), at 0xfbf69530
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/dom/src/build/nsGlobalWindow.o"
  [47] GlobalWindowImpl::RunTimeout(0xd0d4d8, 0xa94668, 0xfdc3aa88, 0x1,
0xff2b5eec, 0xfdb2f160), at 0xfbfa6c9c
  [48] GlobalWindowImpl::TimerCallback(0xa946b8, 0xa94668, 0x97e17353,
0x97e1b271, 0xff35ca24, 0xffbeed08), at 0xfbfa8030
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/xpcom/build/nsTimerImpl.o"
  [49] nsTimerImpl::Fire(0xa946b8, 0x1, 0xff35ca24, 0xffbee9c4, 0xfe35155b,
0x378), at 0xfdb28c58
  [50] handleTimerEvent(0xd40558, 0x1, 0x0, 0x0, 0x0, 0x0), at 0xfdb29014
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/xpcom/build/plevent.o"
  [51] PL_HandleEvent(0xd40558, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfdb13358
  [52] PL_ProcessPendingEvents(0x1569d8, 0x0, 0x0, 0x0, 0x0, 0x0), at 0xfdb13098
dbx: warning: can't find file
"/shared/bigtmp2/mozilla/2003-06-14-08-trunk_cvs/objdir_ws7_gtk/xpcom/build/nsEventQueue.o"
  [53] nsEventQueueImpl::ProcessPendingEvents(0x1569a8, 0x0, 0x0, 0x0, 0x0,
0x0), at 0xfdb17288
  [54] event_processor_callback(data = 0x1569a8, source = 7, condition =
GDK_INPUT_READ), line 188 in "nsAppShell.cpp"
  [55] our_gdk_io_invoke(source = 0x296b70, condition = G_IO_IN, data =
0x1c2260), line 72 in "nsAppShell.cpp"
dbx: warning: can't find file
"/home/gisburn/package-builds/glib/glib-1.2.8/objdir/giounix.lo"
  [56] g_io_unix_dispatch(0x2ec5c8, 0xffbeeda0, 0x1c2260, 0xff3e4270,
0xff35ca24, 0xffbeed08), at 0xfe2b2dc8
dbx: warning: can't find file
"/home/gisburn/package-builds/glib/glib-1.2.8/objdir/gmain.lo"
  [57] g_main_dispatch(0xffbeeda0, 0x108330, 0x1, 0x0, 0xfe35155b, 0x378), at
0xfe2b6dc8
  [58] g_main_iterate(0x1, 0x1, 0x0, 0x0, 0x0, 0x0), at 0xfe2b7bcc
  [59] g_main_run(0x1c2218, 0x1c2218, 0x0, 0x0, 0x0, 0x0), at 0xfe2b7f64
dbx: warning: can't find file
"/home/gisburn/package-builds/gtk+/gtk+-1.2.8/objdir/gtk/gtkmain.lo"
  [60] gtk_main(0x1569a8, 0x0, 0xffbeeef8, 0x0, 0x0, 0x0), at 0xfe4d60a0
  [61] nsAppShell::Run(this = 0x3d89c8), line 328 in "nsAppShell.cpp"
  [62] nsAppShellService::Run(this = 0x3e5d38), line 478 in
"nsAppShellService.cpp"
  [63] main1(argc = 1, argv = 0xffbef364, nativeApp = 0x3d7828), line 1291 in
"nsAppRunner.cpp"
  [64] main(argc = 1, argv = 0xffbef364), line 1670 in "nsAppRunner.cpp"
-- snip --
Depends on: 185357
Summary: Crash while printing www.stern.de → Crash while printing www.stern.de [@ nsIFrame::SetNextSibling]
*** Bug 227762 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

14 years ago
WFM mozilla1.7b(linux installer with talkback) and Xprint 009...
Severity: normal → critical
Keywords: crash

Comment 3

14 years ago
WFM with Mozilla 1.7rc1 and Windows XP SP1
Ok, a 20050318 build hangs on print preview, but a 2005030323 trunk build crashes.
Talkback ID: TB4559468W
This leads to bug 262403. That bug has been fixed, so this could be fixed in
tomorrow's builds. Needs to be checked.
Depends on: 262403
Ok, doesn't crash anymore in 20050324 build. Most likely fixed by bug 262403.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsIFrame::SetNextSibling]
You need to log in before you can comment on or make changes to this bug.