Upgrade install deletes plugin directory

VERIFIED DUPLICATE of bug 69153

Status

VERIFIED DUPLICATE of bug 69153
16 years ago
14 years ago

People

(Reporter: qucae, Assigned: ssu0262)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Upgrading from 1.2.1 to the current test build of 1.4 by installing to the same
directory deletes everything in your plugin directory.  There is a warning that
files will be deleted, but most programs usually only delete their own files,
not ones added by the user since install.  I saw no obvious warning my plugins
would not be kept.  This is not very user friendly (especially for those that do
not remember exactly where all the linked plugins installed actually exist on
their computer).

I found a similar defect already in existence (76458), but it is very ancient. 
I'm very shocked this behvior still exists.  I realize this is free software,
but this behavior is very arcane

Reproducible: Always

Steps to Reproduce:
1.  Install an older version of Mozilla on Liunx.  Install some plugins
2.  Install the current 1.4 build and select to use the same directory
3.  When prompted about an older version in that location, select delete

Actual Results:  
All my existing plugins were deleted

Expected Results:  
One of the following would be much improved:

1)  Offer an upgrade option!  This is fairly standard with software.  If plugin
support has changed, tell the user.  This would preserve plugins and skins.
2)  Only delete files installed by Mozilla.  Leave the plugin directory alone
3)  At least give the user a very obvious warning all plugins will be lost

Updated

16 years ago
QA Contact: bugzilla → gbush

Comment 1

16 years ago
duplicate of bug 69153

*** This bug has been marked as a duplicate of 69153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.