[DOGFOOD][PP][Regression]: Thread panes don't load after migration.

VERIFIED FIXED in M12

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: sspitzer)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Using 12-07-08m12 commercial build on Mac OS 8.5.1

After migrating a profile (either POP or IMAP), thread panes don't load message
header list within the intial mail session.  The status bar reports how many
headers were downloaded, but nothing appears in the thread pane.  Changing to
another folder and back doesn't help.  Next session will indeed load the thread
pane for inbox and when changing to other folders.

This problem doesn't occur when setting up new profiles/accounts.

1.  Migrate an IMAP account from 4.x, go to Mail window.
2.  Expand the IMAP account server, select INBOX and Get Msg.
    Note the status bar text indicates it's looking for and finding folders,
downloading headers for INBOX.  Finally status is Document Done.
    There is nothing in the thread pane, although it is a popilated INBOX.
3.  Switch to another IMAP folder.
    Nothing appears in the thread pane.
4.  Switch back to INBOX.
    Nothing appears in the thread pane.
5.  Exit and relaunch, open INBOX.
    Now threads are listed in threadpane for INBOX and other populated folders.

Same problem during initial session after POP migration.
Cannot reproduce on NT or Linux.
(Reporter)

Updated

19 years ago
QA Contact: gbush → laurel
(Reporter)

Comment 1

19 years ago
Forgot to add that I did provide proper login password at dialog. No
authentication failure involved in this problem.
Summary: [PP][Regression]: Thread panes don't load after migration. → [DOGFOOD][PP][Regression]: Thread panes don't load after migration.
Target Milestone: M13
eish, this sounds nasty.   marking m13, I've got other dogfood bugs before this
one.

paul, can you try to reproduce this?

Comment 3

19 years ago
I didn't see this problem if I use single new server for yesterday's build.
But I saw problem happened after I had migrated profile with multiple news
server....
ok, I'll try on today's build with multiple news servers.

thanks for the extra info.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 5

19 years ago
Putting on the PDT+ radar.
(Reporter)

Updated

19 years ago
Whiteboard: [PDT+]
(Reporter)

Comment 6

19 years ago
I see this when migrating accounts which do not have multiple news servers. I'm
using profiles having 1 mail account(IMAP or POP) and only one news server.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 7

19 years ago
Putting on the PDT+ radar.

Comment 8

19 years ago
Since I have narrowed down for the bug#21170. I agree for put bug#21170 for
duplicate of this bug. Lisa, Phil & Seth, how do you think?

Comment 9

19 years ago
And I suggest to narrow down this bug for dealing with multiple profiles since
problem not happened if I only have single profile in 4.7 and migrated to 5.0.

Comment 10

19 years ago
Yes, go ahead and mark bug 21170 a dup of this one. Thanks.

Comment 11

19 years ago
*** Bug 21170 has been marked as a duplicate of this bug. ***
I can help on this one. I will try to reproduce the problem and then i will do some debugging.
I have an hard time to reproduce this bug. I wonder if it was related to the IMAP problem I saw 2 days ago but have
disapear now.

Anyway, LAUREL, can you stuffit your 4.x account folder which you reproduce the problem (if it's a test account and
not a personal one) and send it to me. I need the folder that should be located at: <system folder>
:preferences:Netscape users:<your account name>
LAUREL, you can also share the directory via Apple File Sharing.
(Reporter)

Comment 15

19 years ago
Well, due to some other problems yesterday I did a clean-up on my 4.7 profiles.
I'm recreating some now and will share them when I'm done and let you know.

The deal basically is that I had multiple profiles on 4.7, a mix of IMAP and
POP. I blew away mozilla registry and the 5.0 users directory and started
mozilla via installer. I migrated IMAP (my main "laurel" account) first.  The
others are test accounts on nsmail-1.

Test account user names having password of l00N!e (lowercase L, two
zeros,exclamation,lowercase E):
spwilliams
spjones
I am still not able to reproduce the problem despite that now I have laurel users folders. Laurel, do you reproduce
the problem if you migrate first spwilliams or spjones?
(Reporter)

Comment 17

19 years ago
I've tried migrating my account/laurel first and I also tried (after wiping out
5.0 user files and mozregistry) doing Jones first. Both cases IMAP was first
migration.
(Reporter)

Comment 18

19 years ago
Maybe Karen (huang) could also share her files to see if you can find
similarities in the configurations.
Here is what I am doing:
1) Integrate Laurel accounts (Laurel, Jones & William) into 4.7 (need some magic trick!).
2) Start "Laurel Carson" account under 4.7 and change the identity name from laurel to ducarroz (as she refuse to
give me her personnal password :-))
3) delete my Mozilla Registry file and rename my Mozilla:Users50 to something else (same thing as deleting the
folder but less destructive!)
4) Start Mozilla with the installer command file
5) Choose either "Laurel" or "William" account and start
6) The profile is migrated
7) Open messenger (use the little icon at the bottom left of the browser page
8) Expand the IMAP account and select the Inbox folder
9) Type my password in the promt and press ok
10) ...and wait...

For me it works fine, it take about a minute to download my 2000 messages but at the end I can see them. Did I miss
a step?
I haven't tried with a commercial release build, only with a Mozilla debug build from this morning. I will do that
next...
(Reporter)

Comment 21

19 years ago
No I don't see that you missed any steps.

I just tried it again migrating the POP account first and it did the same thing:
when I did a Get Msg and logged in correctly, the status bar indicated messages
were retrieved but they never displayed in the thread pane.
I am a little but confuse! What are you not seeing exactly?

1) the whole thread pane is empty
2) some message are displayed but not all of them
3) something else

Comment 23

19 years ago
left panel is fine, but right panel is totally blank.
Only servers' folders, the messages' headers not display at all in the thread
pane, so cannot see the messages, either.

Comment 24

19 years ago
I have recreated/investigated this problem yesterday.
Please see bug#21170 for more information.

The result that I got for yesterday was:
when you have "only single profile" existing in 4.7, the problem won't happen.
After you create the second profile from 4.7 and migrated to 5.0 -> problem
happened -- the second profile will only with mail and news servers' folders,
but all the messages on the right side messages' headers and messages were
totally disappear/blank!! A little similar to bug#20910 but just different OS
with different symptom.

Comment 25

19 years ago
jf - perhaps this has to do w/speed of machine?
sure, I am not using the same cpu, the same connection, etc... I think I would
have to come to the office tomorrow and try to debug on directly on Laurel Mac
(Reporter)

Comment 27

19 years ago
To answer ducarroz' question from 13:48 comments today:

The thread pane is entirely blank, it doesn't display any headers list -- NONE.
The status bar does reflect the text indicating headers were retrieved.
Folders do show in folder pane.
To reiterate my original description -- if you quit and come back into the same
profile, all is OK and thread pane displays headers.  It's just the initial mail
session when migrating.
Status: NEW → ASSIGNED
jfd: putterman and I are trying to reproduce this now on my mac.

hopefully, we'll figure it out before tomorrow.
thanks guys to taking the relay. I am a little bite tired with this bug. Let me
know if you find something or if you need my help.
Target Milestone: M13 → M12
ok, on the 12-8-99 commercial build, I can reproduce this problem
on the 12-9-99 commercial build, I can't.

laurel sees the same thing, but she is double checking everything.

waiting for feedback from laurel before marking this works for me.
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 31

19 years ago
Yeah, at least it's finally good that Seth was able to see this using
yesterday's build.

I have run through this scenario 3 times using the dec09 commercial build.  Each
time and each profile migrated I can see the thread pane header list within the
initial migration session.

I'll mark verified.  OK using 12-09-10m12 commercial build on Mac OS 8.5.1
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.