Java i386 1.4.2 plugin crashes mozilla after identification

RESOLVED DUPLICATE of bug 210925

Status

--
critical
RESOLVED DUPLICATE of bug 210925
16 years ago
8 years ago

People

(Reporter: beanladen, Assigned: joshua.xia)

Tracking

({crash, regression, stackwanted})

Trunk
x86
Linux
crash, regression, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030625
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030625

Own build 1.4rc3 with gcc2.95.3 Linux i686. Newest Sun java 1.4.2 final installed.
symlink to ns610/libjavaplugin_oji.so, not  ns610-gcc3.2, since my Mozilla was 
compiled with gcc.2.95.3.



Reproducible: Always

Steps to Reproduce:
1.goto given page
2.give account and pass
3.press 'anmelden'
4.watch Mozilla crashing :-<

Actual Results:  
Mozilla crashes with the following message:
INTERNAL ERROR on Browser End: Plugin instance index out of bounds 13111
System error?:: Resource temporarily unavailable


Expected Results:  
Goto Homebanking page without crashing !

This worked with 1.4rc3 with the old plugin 1.4.1_01.
Interestingly, this works again (with the new Java 1.4.2 !) when I still link
against the old 1.4.1_01 libjavaplugin_oji.so !
(Reporter)

Comment 1

16 years ago
add. info: This can be tested with invalid account and pass:
type 1234567890, pass 12345.
(Reporter)

Comment 2

16 years ago
Sorry: build is 1.5a trunk, of course, not 1.4rc3.

Comment 3

16 years ago
confirming using 1.4RC3 + JRE 1.4.2 final (gcc3.2).
Looks like a regression from JRE 1.4.2.

Java Log shows:
Sparkasse Karlsruhe Internetbanking Version 1.06
Die Druckfunktion wird für dieses Betriebssystem nicht unterstützt!Linux
BAuthent 2.0.0 2000-06-06 12.10.43
BAuthent: No authentication used
USING IDEA as Cipherspec
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, regression, stackwanted

Comment 4

16 years ago
Bug 210925 looks similar.
(Reporter)

Comment 5

16 years ago
This seems indeed to be a duplicate of #210925.

*** This bug has been marked as a duplicate of 210925 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
It will be fixed in 1.4.2_03. 

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.