does not accept java VM plugin, default or from java.com site.

RESOLVED DUPLICATE of bug 208573

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 208573
15 years ago
14 years ago

People

(Reporter: Joey Pruitt, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

When I try to install the Java VM plugin, wether it be the one that
automatically installs or from java.com website it gives me the error:

LoadPlugin: failed to initialize shared library
/usr/local/mozilla/plugins/libjavaplugin_oji.so
[/usr/local/mozilla/plugins/libjavaplugin_oji.so: undefined symbol:
GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

or something very similar. I used the ns4 version of JavaVM plugin, it didn't
give any errors, but it didn't recognize the plugin either. Thanks for helping
me with this.

Reproducible: Always

Steps to Reproduce:
1.Install Java
2.Copy plugin to the /plugins folder
3.Start mozilla

Actual Results:  
Mozilla refuses to accept JavaVM plugins (all)

Expected Results:  
Accept plugins and let me exec the applet smoothly.

JavaVM(j2re1.4.1_03)for netscape 4:Starts fine, but appears to not realize that
the plugin is assoiated with Java applets.

JavaVM(j2re1.4.1_03)for netscape 6:LoadPlugin: failed to initialize shared
library /usr/local/mozilla/plugins/libjavaplugin_oji.so
[/usr/local/mozilla/plugins/libjavaplugin_oji.so: undefined symbol:
GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

JavaVM(j2re1.4.1_03) for netscape 6.1:LoadPlugin: failed to initialize shared
library /usr/local/mozilla/plugins/libjavaplugin_oji.so
[/usr/local/mozilla/plugins/libjavaplugin_oji.so: undefined symbol:
GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

Comment 1

15 years ago
Dupe of bug 208573?

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 208573 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.