A vertical scrollbar appears in popup when the heigth of a table is set to "100%"

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: marcb, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030628 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030628 Mozilla Firebird/0.6

The html document is made of a single <table>. The document is generated from
javascript and opened in a popup window. Note that the size of the popup is
modified after the document has been loaded.
When the height attribute of the table is set to 100% a vertical scrollbar
appears. Whatever the size of the popup. In the examples the size of the window
is sufficient to remove any need of scrollbars. If you maximize/minimise the
window, the scrollbar disappears.
The example page presents several cases. I was preparing a test connected to bug
#88035 when I've found the problem. The first case is an example of that bug.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Vertical scrollbar appears

Expected Results:  
No vertical scrollbar should appear
(Reporter)

Comment 1

15 years ago
I meant "maximize/restore" not "maximize/minimise".   ;)

Comment 2

15 years ago
This works for me with the 20030629 build on W2K.
Try a new build with a fresh profile.

Comment 3

15 years ago
I can confirm this behaviour using Mozilla/5.0 (Windows; U; WinNT4.0; en-US;
rv:1.5a) Gecko/20030629 Mozilla Firebird/0.6

Unfortunately I currently don't have a recent SeaMonkey build available. Marc,
do you see this also in latest SeaMonkey build?
OS: Windows 98 → Windows NT
(Reporter)

Comment 4

15 years ago
I've tested it once again with Firebird and Mozilla nightly builds. The problem
is still there.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030629 Mozilla Firebird/0.6

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030629
(Reporter)

Comment 5

15 years ago
By the way, can someone tell me why this bug doesn't appear in my list?
It would be easier to keep track. Not that I've reported many, this is only the
second one, but...   ;)

Comment 6

15 years ago
When javascript permissions are set so javascript cannot resize or move a
window, all the links at http://tests.bd.dyndns.org/Mozilla/table-test.html have
a vertical scroll bar and are of the same size.  No horizontal scrollbars.

For whatever it's worth...

Comment 7

15 years ago
remove ' topmargin="0" leftmargin="0" marginwidth="0" marginheight="0"' from the
body tag on the second link and you get both scrollbars.

Comment 8

15 years ago
Created attachment 127255 [details]
another test case

another test case with fewer tags so it's cleaner

Comment 9

15 years ago
I just added some more test cases.  I also noticed that I can create a window
with scrollbars=no yet when resized (by the script) the scrollbars appear.

I'm using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030516
Mozilla Firebird/0.6

Comment 10

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030727 Mozilla Firebird/0.6.1

Confirmed this behaviour using Adam A. Koch's test cases
Still happening on 20030830 firebird and seamonkey builds. Moving over to browser.
Assignee: blake → other
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firebird → Browser
QA Contact: asa → ian
Version: unspecified → Trunk

Comment 12

15 years ago
FWIW, all testcases in attachment 127255 [details] show no scrollbars with 1.5b on linux
-- before and after maximize/restore
All testcases and URL works for me, 2004-07-22-05 trunk Linux.

There are some remaining issues covered by bug 227808, but this bug can be
resolved WFM unless someone still is having problems with the URL/testcase here.
Keywords: testcase

Comment 14

12 years ago
wfm
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20061231 Minefield/3.0a2pre

Comment 15

12 years ago
resolving WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.