Move from deprecated LoadIcon() to LoadImage()

RESOLVED WORKSFORME

Status

()

Core
XUL
P4
enhancement
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: David G King, Unassigned)

Tracking

Trunk
Future
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
As per the above URL from a Microsoft MSDN article, LoadIcon (and LoadIconW)
have been deprecated and replaced by LoadImage (and LoadImageW).

I have marked this as an enhancement as it isn't the cause of any leaks (GDI or
otherwise) that I've found, and thus is just about keeping up with technology.
Note: LoadImage does require a Destroy process if it isn't loaded with sharing
enabled.
http://lxr.mozilla.org/seamonkey/search?string=LoadIcon%5C%28 shows no calls to
LoadIcon in Mozilla GFX code (or anywhere in the Gecko core for that matteR). 
There are several callers in test apps, the ActiveX plugin, plugin samples,
xpinstall, and mailnews -- the best course of action is probably to file one bug
per module involved, assigned to the right components....
(Reporter)

Comment 2

15 years ago
Changing to XP Toolkit/Widgets for code in /widget/src/windows/
Component: GFX: Win32 → XP Toolkit/Widgets
-> XP Toolkit/Widgets owner
Assignee: kmcclusk → jaggernaut
Priority: -- → P4
QA Contact: ian → jrgm
Target Milestone: --- → Future
Assignee: jag → nobody

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.