Open Bug 211079 Opened 19 years ago Updated 9 months ago

Can't select text between absolutely positioned div's (Google PDFs)

Categories

(Core :: DOM: Selection, defect, P5)

defect

Tracking

()

REOPENED

People

(Reporter: sgifford, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

If a page consists of a number of <DIV> elements with absolute positioning, it's
impossible to select text from more than one of these DIVs at the same time. 
This is especially conspicous with Google's PDF-to-HTML converter, which
converts a PDF document into a series of absolutely-positioned <DIV> elements
with the appearance of a single document.


Reproducible: Always

Steps to Reproduce:
1. Visit the sample URL (or the attached simplified test case)
2. Begin a selection on the top line (eg, click at the beginning of XTEST and
hold the mouse button)
3. Attempt to complete the selection on the second line (drag the mouse cursor
down to the second line and in a few characters)

Actual Results:  
No part of the second line was selected.

Expected Results:  
Selected part of the second line; behaved like it would have if this page were
just normally flowed text.

Selection also behaves strangely on this page if you attempt to start a
selection outside of text (eg between the first and second lines) or dismiss a
current selection by clicking outside of text.
Attached file Test case
Summary: Can't select text between absolutely positioned div's → Can't select text between absolutely positioned div's (Google PDFs)
This bug is also present in FireBird 20030703.
*** Bug 221057 has been marked as a duplicate of this bug. ***
H/OS -> All/All
URL is replaced with working one

Depends on: 53966
Looks like the patch for bug 53966 fixed this bug, too. Tested with a Linux
trunk build from today.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Linux build 211079

It works very unstable. To select the text in the testcase one should carefully
move mouse along each line of the text. 

And the bug is still easy to reproduce:

1. Open the testcase
2. Push the left mouse button at the word "XTEXT"
3. Move the mouse to the right lower corner of the browser window.
4. Only several letters of the text are selected

Expected result: all the text sould be selected

Reopenning...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
> Linux build 211079

Ops. I meant Linux build 2004072005

Rob: This one isn't completely fixed after you checked in your patch for bug
53966. See comment 7.
Assignee: mjudge → nobody
QA Contact: pmac → selection

Bulk-downgrade of unassigned, >=5 years untouched DOM/Storage bugs' priority.

If you have reason to believe this is wrong (especially for the severity), please write a comment and ni :jstutte.

Severity: normal → S4
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.