select/combo box with active style set in CSS does not drop down

VERIFIED DUPLICATE of bug 163503

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 163503
15 years ago
13 years ago

People

(Reporter: David Fraser, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-za; rv:1.3.1) Gecko/20030609
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-za; rv:1.3.1) Gecko/20030609

In a simple page with a combo box/select widget, that has a css style sheet with
attributes set for ":active", the combo box does not drop down properly if selected.
This is consistently reproducible on Linux, but not Windows
This is reproducible in 1.4rc3 and all releases since 1.1 (but not 1.0)

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.sjsoft.com/home/davidf/combostyle.htm
2. Click on the combo box
Actual Results:  
The selected item in the combo box is underlined and changes color, but the box
does not "drop down"

Expected Results:  
The box should have dropped down to allow the user to click on another value

*** This bug has been marked as a duplicate of 163503 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.